www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - Re: opStar

Michel Fortin Wrote:

 On 2007-11-10 04:21:41 -0500, "Janice Caron" <caron800 googlemail.com> said:
 ...and since we now have opStar() to overload *p

Hum, is it just me or is the name of this operator inconsistant? Aren't operators in D supposed to be named after what they do instead of what they look like in order to discourage programmers from changing the operator's meaning? So why isn't opStar named opDereference, or opDeref for short? -- Michel Fortin michel.fortin michelf.com http://michelf.com/

Nov 10 2007