www.digitalmars.com         C & C++   DMDScript  

D.gnu - [Bug 131] New: can't compile current dub

Date: Thu, 12 Jun 2014 16:49:56 +0100
MIME-Version: 1.0
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable


            Bug ID: 131
           Summary: can't compile current dub
           Product: GDC
           Version: development
          Hardware: x86
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: Normal
         Component: gdc
          Assignee: ibuclaw gdcproject.org
          Reporter: ketmar ketmar.no-ip.org

i just tried to compile dub(2e1f98ac=E2=80=A6 Jun,12) with gdc(8b77c001=E2=
=80=A6 Jun,12) and
gdc fails with:

source/dub/packagemanager.d: In member function 'serialize':
source/dub/packagemanager.d:863: error: cannot cast expression of type stri=
to void

4.9 branch compiles the same code without problems.

You are receiving this mail because:
You are watching all bug changes.
Jun 12 2014