www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - Where is run.dlang.org running?

reply Adam D. Ruppe <destructionator gmail.com> writes:
All its things that communicate with outside services have been 
failing with dns lookup failures, though the services are still 
up. It is probably just a dns configuration mistake or perhaps an 
outbound firewall. Probably an easy fix if one of us can just log 
into that server......
Apr 05
parent reply Petar Kirov [ZombineDev] <petar.p.kirov gmail.com> writes:
On Sunday, 5 April 2020 at 13:58:53 UTC, Adam D. Ruppe wrote:
 All its things that communicate with outside services have been 
 failing with dns lookup failures, though the services are still 
 up. It is probably just a dns configuration mistake or perhaps 
 an outbound firewall. Probably an easy fix if one of us can 
 just log into that server......
Just checked, and for me it's working ok. I am one of the maintainers, though it's not me who had set the server up. As far as I know, the DNS configuration and the server itself is managed by the dlang.org admin.
Apr 05
parent reply Adam D. Ruppe <destructionator gmail.com> writes:
On Sunday, 5 April 2020 at 18:36:37 UTC, Petar Kirov [ZombineDev] 
wrote:
 Just checked, and for me it's working ok.
The specific problem several of us have seen for a while is the "Shorten" button on the UI. Click that and the api thing return a 500 code (which on the ui is just the button apparently doing absolutely nothing) and the response is object.Exception ../../../.dub/packages/vibe-core-1.8.1/vibe-core/source/ ibe/core/net.d(71): Failed to lookup host 'is.gd'. ----------------??:? [0x8d5335]??:? [0x8fa47a]??:? [0x8e08fd]exception.d:516 [0x46e2d5]exception.d:436 [0x417145]net.d:71 [0x71796d]net.d:32 [0x7174f5]client.d:693 [0x60eb7c]client.d:610 [0x60c9b8]client.d:582 [0x60a78f]client.d:85 [0x609d07]client.d:75 [0x609adb]apiv1.d:132 [0x40539a]rest.d:1527 [0x4c4849]rest.d:1527 [0x4c3c4c]router.d:218 [0x6238ce]router.d:674 [0x625f83]router.d:607 [0x623636]router.d:211 [0x62345d]server.d:2284 [0x62ba0f]server.d:247 [0x629f46]server.d:239 [0x629726]server.d:2040 [0x634451]task.d:656 [0x729864]task.d:674 [0x7271f1]task.d:400 [0x726a05]??:? [0x8d7d41] Very similar on "Export gist".
  As far as I know, the DNS configuration and the server itself 
 is managed by the dlang.org admin.
hmm, it is possible I'm wrong about the dns itself being the problem, maybe it something else - someone in the irc chatroom suggested it could be a bug in the vibe framework rather than a config issue cuz they saw it on another server before. But still it is annoying that it doesn't work so wanna rule things out at least.
Apr 05
parent Petar Kirov [ZombineDev] <petar.p.kirov gmail.com> writes:
On Sunday, 5 April 2020 at 19:00:16 UTC, Adam D. Ruppe wrote:
 On Sunday, 5 April 2020 at 18:36:37 UTC, Petar Kirov 
 [ZombineDev] wrote:
 Just checked, and for me it's working ok.
The specific problem several of us have seen for a while is the "Shorten" button on the UI. Click that and the api thing return a 500 code (which on the ui is just the button apparently doing absolutely nothing) and the response is object.Exception ../../../.dub/packages/vibe-core-1.8.1/vibe-core/source/ ibe/core/net.d(71): Failed to lookup host 'is.gd'. ----------------??:? [0x8d5335]??:? [0x8fa47a]??:? [0x8e08fd]exception.d:516 [0x46e2d5]exception.d:436 [0x417145]net.d:71 [0x71796d]net.d:32 [0x7174f5]client.d:693 [0x60eb7c]client.d:610 [0x60c9b8]client.d:582 [0x60a78f]client.d:85 [0x609d07]client.d:75 [0x609adb]apiv1.d:132 [0x40539a]rest.d:1527 [0x4c4849]rest.d:1527 [0x4c3c4c]router.d:218 [0x6238ce]router.d:674 [0x625f83]router.d:607 [0x623636]router.d:211 [0x62345d]server.d:2284 [0x62ba0f]server.d:247 [0x629f46]server.d:239 [0x629726]server.d:2040 [0x634451]task.d:656 [0x729864]task.d:674 [0x7271f1]task.d:400 [0x726a05]??:? [0x8d7d41] Very similar on "Export gist".
  As far as I know, the DNS configuration and the server itself 
 is managed by the dlang.org admin.
hmm, it is possible I'm wrong about the dns itself being the problem, maybe it something else - someone in the irc chatroom suggested it could be a bug in the vibe framework rather than a config issue cuz they saw it on another server before. But still it is annoying that it doesn't work so wanna rule things out at least.
Ah, I thought you meant that there was DNS misconfiguration with run.dlang.org / run.dlang.io / tour.dlang.org subdomains (and not the internal DNS config). Unfortunately, the URL shortening has been broken for a while: https://github.com/dlang-tour/core/issues/739 I'll see what I can do.
Apr 05