www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - D3 Feature Request: rename 'in' to 'into'.

The current 'in' expression is something of a misnomer: you're not checking if
a value is *in* an array, but if a value serves as a key *into* an array. This
rename would also free up 'in' for value lookups; make everything a bit clearer.

PS: <-was downs
Feb 17 2010