www.digitalmars.com         C & C++   DMDScript  

digitalmars.empire - running 16bit Empire on a 64bit computer

reply richard Leavitt <richardleavitt65 gmail.com> writes:
I have recently bought a new computer, upgrading from XP pro to 
Windows 7. I have installed DOSBOT and I have it running but it 
is hard to look at and terrible to play. Its just not the same 
and after 30yrs of playing this damn game I now seem to avoid it 
because it's not as fun as it used to be. Its like losing a 
friend. Any help?
Jun 23
next sibling parent Adam D. Ruppe <destructionator gmail.com> writes:
On Friday, 23 June 2017 at 16:05:57 UTC, richard Leavitt wrote:
 I have recently bought a new computer, upgrading from XP pro to 
 Windows 7. I have installed DOSBOT
You mean DOS Box right? That's what I was going to suggest, but you could also perhaps try another VM solution too like virtualbox, qemu, etc. and install XP in there. I believe there's also a port of Empire to 32 bit Windows which you could use but I don't remember where.
Jun 23
prev sibling parent Lucien Baumann <lucien1276 gmail.com> writes:
On Friday, 23 June 2017 at 16:05:57 UTC, richard Leavitt wrote:
 I have recently bought a new computer, upgrading from XP pro to 
 Windows 7. I have installed DOSBOT and I have it running but it 
 is hard to look at and terrible to play. Its just not the same 
 and after 30yrs of playing this damn game I now seem to avoid 
 it because it's not as fun as it used to be. Its like losing a 
 friend. Any help?
Here's the link to the Windows version: http://ftp.classicempire.com/empirebin.zip You must patch it to be run on Windows 7 (Otherwise it will crash if you open a saved game). Open "winemp.exe" with an hex editor and replace "e8 ff e0 00 00" with "90 90 90 90 90" at address "c6c4".
Jun 27