www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.learn - implib.exe no output files

reply Joel <joelcnz gmail.com> writes:
I got the file here: http://ftp.digitalmars.com/bup.zip

It works on other computers.

I was trying to update to the latest DAllegro 
(https://github.com/SiegeLord/DAllegro5).

Though, I used another computer for the lib files and still 
couldn't get the latest DAllegro5 working.
Jun 18
parent reply Ivan Kazmenko <gassa mail.ru> writes:
On Sunday, 18 June 2017 at 07:41:27 UTC, Joel wrote:
 I got the file here: http://ftp.digitalmars.com/bup.zip

 It works on other computers.

 I was trying to update to the latest DAllegro 
 (https://github.com/SiegeLord/DAllegro5).

 Though, I used another computer for the lib files and still 
 couldn't get the latest DAllegro5 working.
The .bat files in https://github.com/SiegeLord/DAllegro5 work fine for me. Could you please be more specific about what exactly you are doing, and what went wrong? Keep in mind that you need Allegro binaries (e.g. from http://liballeg.org/download.html#windows) to use implib. Ivan Kazmenko.
Jun 18
parent reply Joel <joelcnz gmail.com> writes:
On Sunday, 18 June 2017 at 09:48:31 UTC, Ivan Kazmenko wrote:
 On Sunday, 18 June 2017 at 07:41:27 UTC, Joel wrote:
 I got the file here: http://ftp.digitalmars.com/bup.zip

 It works on other computers.

 I was trying to update to the latest DAllegro 
 (https://github.com/SiegeLord/DAllegro5).

 Though, I used another computer for the lib files and still 
 couldn't get the latest DAllegro5 working.
The .bat files in https://github.com/SiegeLord/DAllegro5 work fine for me. Could you please be more specific about what exactly you are doing, and what went wrong? Keep in mind that you need Allegro binaries (e.g. from http://liballeg.org/download.html#windows) to use implib. Ivan Kazmenko.
I have the dll's in the same directory where I run the create lib .bat file. It displays the normal stuff, but no lib files! I'm wondering if implib needs to be worked on.
Jun 19
parent reply Ivan Kazmenko <gassa mail.ru> writes:
On Monday, 19 June 2017 at 23:11:29 UTC, Joel wrote:
 On Sunday, 18 June 2017 at 09:48:31 UTC, Ivan Kazmenko wrote:
 On Sunday, 18 June 2017 at 07:41:27 UTC, Joel wrote:
 I got the file here: http://ftp.digitalmars.com/bup.zip

 It works on other computers.

 I was trying to update to the latest DAllegro 
 (https://github.com/SiegeLord/DAllegro5).

 Though, I used another computer for the lib files and still 
 couldn't get the latest DAllegro5 working.
The .bat files in https://github.com/SiegeLord/DAllegro5 work fine for me. Could you please be more specific about what exactly you are doing, and what went wrong? Keep in mind that you need Allegro binaries (e.g. from http://liballeg.org/download.html#windows) to use implib. Ivan Kazmenko.
I have the dll's in the same directory where I run the create lib .bat file. It displays the normal stuff, but no lib files! I'm wondering if implib needs to be worked on.
Sorry, that's still not specific enough. I've just tested this in a fresh directory: 1. Get https://github.com/SiegeLord/DAllegro5 2. Get https://github.com/liballeg/allegro5/releases/download/5.2.2.0/allegro-mingw-gcc6.2.0-x86-static-5.2.2.zip 3. Put, for example, allegro-5.2.dll from the archive to DAllegro5 directory. 4. Run create_import_libs.bat, here is the output: ----- ...>rem This batch file creates import dlls in the current folder and strips the version number ...>rem because OPTLINK sucks. Digital Mars Import Library Manager Version 7.6B1n Copyright (C) Digital Mars 2000. All Rights Reserved. Input is a Windows NT DLL file 'allegro-5.2.dll'. Output is a Windows NT import library. Digital Mars Import Library Creator complete. ----- 5. Now I got allegro.lib in the directory. Which of these steps fails for you, and how? Ivan Kazmenko.
Jun 21
parent Joel <joelcnz gmail.com> writes:
On Wednesday, 21 June 2017 at 11:30:56 UTC, Ivan Kazmenko wrote:
 [...]
Step 5. I don't get any lib files. I got lib files on another computer, though.
Jun 23