www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.dwt - Dwt2 build snippet10 link error

reply tuanhoanganh <hatuan05 gmail.com> writes:
--0016e64bb7ba782177049415cf2c
Content-Type: text/plain; charset=UTF-8

I am newbie of D language.
I use D v1.0.65 and tango 1.0 (lastest truck)
When i run "rake base swt" everything ok but when i run
dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
-JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
-odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
d:\D\dwt2\Snippet10.d
(I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
-ID:\D\dwt2\dwt2\imp
 -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
-odD:\D\
dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
OPTLINK (R) for Win32  Release 8.00.8
Copyright (C) Digital Mars 1989-2010  All rights reserved.
http://www.digitalmars.com/ctg/optlink.html
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
 Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
 Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
org7eclipse3swt8graphics5Color5ColorZv
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
 Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
org7eclipse3swt8graphics5Color5ColorZv
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
 Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
lipse3swt8graphics4Path4PathZv
.....

How to fix it.
Tuan Hoang Anh
Thank in advance.

--0016e64bb7ba782177049415cf2c
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

I am newbie of D language.<br>I use D v1.0.65 and tango 1.0 (lastest truck)=
<br>When i run &quot;rake base swt&quot; everything ok but when i run<br>dm=
d -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp -JD:\D=
\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op -odD:\D\dw=
t2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d<br>
(I copyed snippet10.d from it directory to d:\D\dwt2\) i have error<br>D:\D=
\dwt2&gt;dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2=
\imp<br>=C2=A0-JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt=
2\res -op -odD:\D\<br>
dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d<br>=
OPTLINK (R) for Win32=C2=A0 Release 8.00.8<br>Copyright (C) Digital Mars 19=
89-2010=C2=A0 All rights reserved.<br><a href=3D"http://www.digitalmars.com=
/ctg/optlink.html">http://www.digitalmars.com/ctg/optlink.html</a><br>
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)<br>=C2=A0Error 42: Symbol Undef=
ined _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e<br>clipse3swt8gra=
phics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path<br>D:\D\dwt2\dwt2\=
obj\Snippet10.obj(Snippet10)<br>
=C2=A0Error 42: Symbol Undefined _D3org7eclipse3swt8graphics2GC2GC13setBack=
groundMFC3<br>org7eclipse3swt8graphics5Color5ColorZv<br>D:\D\dwt2\dwt2\obj\=
Snippet10.obj(Snippet10)<br>=C2=A0Error 42: Symbol Undefined _D3org7eclipse=
3swt8graphics2GC2GC13setForegroundMFC3<br>
org7eclipse3swt8graphics5Color5ColorZv<br>D:\D\dwt2\dwt2\obj\Snippet10.obj(=
Snippet10)<br>=C2=A0Error 42: Symbol Undefined _D3org7eclipse3swt8graphics2=
GC2GC8fillPathMFC3org7ec<br>lipse3swt8graphics4Path4PathZv<br>.....<br><br>=
How to fix it.<br>
Tuan Hoang Anh<br>Thank in advance.<br>

--0016e64bb7ba782177049415cf2c--
Nov 02 2010
next sibling parent Jacob Carlborg <doob me.com> writes:
On 2010-11-02 19:08, tuanhoanganh wrote:
 I am newbie of D language.
 I use D v1.0.65 and tango 1.0 (lastest truck)
 When i run "rake base swt" everything ok but when i run
 dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
 -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
 -odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
 d:\D\dwt2\Snippet10.d
 (I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
 D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
 -ID:\D\dwt2\dwt2\imp
   -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
 -odD:\D\
 dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
 OPTLINK (R) for Win32  Release 8.00.8
 Copyright (C) Digital Mars 1989-2010  All rights reserved.
 http://www.digitalmars.com/ctg/optlink.html
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
   Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
 clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
   Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
 org7eclipse3swt8graphics5Color5ColorZv
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
   Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
 org7eclipse3swt8graphics5Color5ColorZv
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
   Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
 lipse3swt8graphics4Path4PathZv
 .....

 How to fix it.
 Tuan Hoang Anh
 Thank in advance.

Have you linked with the base and swt libraries ? -- /Jacob Carlborg
Nov 03 2010
prev sibling parent tuanhoanganh <hatuan05 gmail.com> writes:
--0016e64bb7babbf5250494275c57
Content-Type: text/plain; charset=UTF-8

I have linked to all file in lib and build with no problem.
Thanks you very much.
Tuan Hoang Anh

On Wed, Nov 3, 2010 at 5:27 PM, Jacob Carlborg <doob me.com> wrote:

 On 2010-11-02 19:08, tuanhoanganh wrote:

 I am newbie of D language.
 I use D v1.0.65 and tango 1.0 (lastest truck)
 When i run "rake base swt" everything ok but when i run
 dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
 -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
 -odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
 d:\D\dwt2\Snippet10.d
 (I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
 D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
 -ID:\D\dwt2\dwt2\imp
  -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
 -odD:\D\
 dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
 OPTLINK (R) for Win32  Release 8.00.8
 Copyright (C) Digital Mars 1989-2010  All rights reserved.
 http://www.digitalmars.com/ctg/optlink.html
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
  Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
 clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
  Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
 org7eclipse3swt8graphics5Color5ColorZv
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
  Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
 org7eclipse3swt8graphics5Color5ColorZv
 D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
  Error 42: Symbol Undefined
 _D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
 lipse3swt8graphics4Path4PathZv
 .....

 How to fix it.
 Tuan Hoang Anh
 Thank in advance.

Have you linked with the base and swt libraries ? -- /Jacob Carlborg

--0016e64bb7babbf5250494275c57 Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: quoted-printable I have linked to all file in lib and build with no problem.<br>Thanks you v= ery much.<br>Tuan Hoang Anh<br><br><div class=3D"gmail_quote">On Wed, Nov 3= , 2010 at 5:27 PM, Jacob Carlborg <span dir=3D"ltr">&lt;<a href=3D"mailto:d= oob me.com">doob me.com</a>&gt;</span> wrote:<br> <blockquote class=3D"gmail_quote" style=3D"margin: 0pt 0pt 0pt 0.8ex; borde= r-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div><div></div><= div class=3D"h5">On 2010-11-02 19:08, tuanhoanganh wrote:<br> <blockquote class=3D"gmail_quote" style=3D"margin: 0pt 0pt 0pt 0.8ex; borde= r-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"> I am newbie of D language.<br> I use D v1.0.65 and tango 1.0 (lastest truck)<br> When i run &quot;rake base swt&quot; everything ok but when i run<br> dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp<br> -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op<br> -odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe<br> d:\D\dwt2\Snippet10.d<br> (I copyed snippet10.d from it directory to d:\D\dwt2\) i have error<br> D:\D\dwt2&gt;dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src<br> -ID:\D\dwt2\dwt2\imp<br> =C2=A0-JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -= op<br> -odD:\D\<br> dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d<br> OPTLINK (R) for Win32 =C2=A0Release 8.00.8<br> Copyright (C) Digital Mars 1989-2010 =C2=A0All rights reserved.<br> <a href=3D"http://www.digitalmars.com/ctg/optlink.html" target=3D"_blank">h= ttp://www.digitalmars.com/ctg/optlink.html</a><br> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)<br> =C2=A0Error 42: Symbol Undefined<br> _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e<br> clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path<br> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)<br> =C2=A0Error 42: Symbol Undefined<br> _D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3<br> org7eclipse3swt8graphics5Color5ColorZv<br> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)<br> =C2=A0Error 42: Symbol Undefined<br> _D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3<br> org7eclipse3swt8graphics5Color5ColorZv<br> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)<br> =C2=A0Error 42: Symbol Undefined<br> _D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec<br> lipse3swt8graphics4Path4PathZv<br> .....<br> <br> How to fix it.<br> Tuan Hoang Anh<br> Thank in advance.<br> </blockquote> <br></div></div> Have you linked with the base and swt libraries ?<br> <br> -- <br><font color=3D"#888888"> /Jacob Carlborg<br> </font></blockquote></div><br> --0016e64bb7babbf5250494275c57--
Nov 03 2010