www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - dmd.1.043.deb is for AMD 64

reply "carlos smith" <carlos-smith sympatico.ca> writes:
Hi !

Just installed Ubuntu 8.04.
Then tried to install dmd.1.043.deb
from http://www.digitalmars.com/d/download.html


Got the following message
    Not the correct architecture AMD 64

Is there a 32 bits version (1.043) available somewhere ?
Apr 15 2009
next sibling parent Walter Bright <newshound1 digitalmars.com> writes:
carlos smith wrote:
 Hi !
 
 Just installed Ubuntu 8.04.
 Then tried to install dmd.1.043.deb
 from http://www.digitalmars.com/d/download.html
 
 
 Got the following message
    Not the correct architecture AMD 64
 
 Is there a 32 bits version (1.043) available somewhere ?

Just download the regular zip file from the same page. It's for 32 bits.
Apr 14 2009
prev sibling parent Jesse Phillips <jessekphillips gmail.com> writes:
On Wed, 15 Apr 2009 03:06:41 -0400, carlos smith wrote:

 Hi !
 
 Just installed Ubuntu 8.04.
 Then tried to install dmd.1.043.deb
 from http://www.digitalmars.com/d/download.html
 
 
 Got the following message
     Not the correct architecture AMD 64
 
 Is there a 32 bits version (1.043) available somewhere ?

you can force an install of the .deb but there is no 64bit compiler of DMD. # dpkg --force-architecture -i dmd.1.043.deb
Apr 15 2009