www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - dlang.org slow?

reply "H. S. Teoh" <hsteoh quickfur.ath.cx> writes:
Is it just me, or has dlang.org been really slow today? Is something
wrong with the site that needs our attention? It takes almost 2 whole
minutes to load a page -- at first I thought my office network screwed
up again, but now I'm at home and it's still like that.


T

-- 
Change is inevitable, except from a vending machine.
Oct 25 2012
next sibling parent reply =?ISO-8859-1?Q?Alex_R=F8nne_Petersen?= <alex lycus.org> writes:
On 26-10-2012 07:01, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is something
 wrong with the site that needs our attention? It takes almost 2 whole
 minutes to load a page -- at first I thought my office network screwed
 up again, but now I'm at home and it's still like that.


 T

Hmm, seems OK to me. Loads within 4 seconds. -- Alex Rønne Petersen alex lycus.org http://lycus.org
Oct 25 2012
parent reply "H. S. Teoh" <hsteoh quickfur.ath.cx> writes:
On Fri, Oct 26, 2012 at 07:02:09AM +0200, Alex Rønne Petersen wrote:
 On 26-10-2012 07:01, H. S. Teoh wrote:
Is it just me, or has dlang.org been really slow today? Is something
wrong with the site that needs our attention? It takes almost 2 whole
minutes to load a page -- at first I thought my office network screwed
up again, but now I'm at home and it's still like that.


[...]
 
 Hmm, seems OK to me. Loads within 4 seconds.

[...] Hmph. Probably a Canadian problem then. :-P T -- "I speak better English than this villain Bush" -- Mohammed Saeed al-Sahaf, Iraqi Minister of Information
Oct 25 2012
parent Nick Sabalausky <SeeWebsiteToContactMe semitwist.com> writes:
On Thu, 25 Oct 2012 22:18:40 -0700
"H. S. Teoh" <hsteoh quickfur.ath.cx> wrote:

 On Fri, Oct 26, 2012 at 07:02:09AM +0200, Alex R=F8nne Petersen wrote:
 On 26-10-2012 07:01, H. S. Teoh wrote:
Is it just me, or has dlang.org been really slow today? Is
something wrong with the site that needs our attention? It takes
almost 2 whole minutes to load a page -- at first I thought my
office network screwed up again, but now I'm at home and it's
still like that.


[...]
=20
 Hmm, seems OK to me. Loads within 4 seconds.

[...] =20 Hmph. Probably a Canadian problem then. :-P =20

I'm getting that, too (although it's not as bad as it was a couple hours ago), and I'm in Cleveland.
Oct 26 2012
prev sibling next sibling parent "Jakob Ovrum" <jakobovrum gmail.com> writes:
On Friday, 26 October 2012 at 04:59:07 UTC, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is 
 something
 wrong with the site that needs our attention? It takes almost 2 
 whole
 minutes to load a page -- at first I thought my office network 
 screwed
 up again, but now I'm at home and it's still like that.


 T

It's being very slow for me at times too. I think the NG server is suffering too, though I only use it through the forum.dlang.org front-end (getting a variety of HTTP error messages and timeouts).
Oct 25 2012
prev sibling next sibling parent "Daniel =?UTF-8?B?S296w6FrIg==?= <kozzi11 gmail.com> writes:
On Friday, 26 October 2012 at 04:59:07 UTC, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is 
 something
 wrong with the site that needs our attention? It takes almost 2 
 whole
 minutes to load a page -- at first I thought my office network 
 screwed
 up again, but now I'm at home and it's still like that.


 T

Same here
Oct 25 2012
prev sibling next sibling parent Jacob Carlborg <doob me.com> writes:
On 2012-10-26 07:01, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is something
 wrong with the site that needs our attention? It takes almost 2 whole
 minutes to load a page -- at first I thought my office network screwed
 up again, but now I'm at home and it's still like that.

I think I had some problems yesterday, I didn't investigate further. -- /Jacob Carlborg
Oct 25 2012
prev sibling parent reply "Maxim Fomin" <maxim maxim-fomin.ru> writes:
On Friday, 26 October 2012 at 04:59:07 UTC, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is 
 something
 wrong with the site that needs our attention? It takes almost 2 
 whole
 minutes to load a page -- at first I thought my office network 
 screwed
 up again, but now I'm at home and it's still like that.


 T

Fully conform. The server replies to slow: sometimes it open reference pages quickly, sometimes with considerable and inappropriate delay. Forum also doesn't work quite well always. By some reason its splits topics, like this one. Some time ago it could go hang in endless loop while posting messages. Now the situation is better - data is transferred to the server but delay is also inappropriate long.
Oct 26 2012
parent reply "Rob T" <rob ucora.com> writes:
On Friday, 26 October 2012 at 15:17:34 UTC, Maxim Fomin wrote:
 On Friday, 26 October 2012 at 04:59:07 UTC, H. S. Teoh wrote:
 Is it just me, or has dlang.org been really slow today? Is 
 something
 wrong with the site that needs our attention? It takes almost 
 2 whole
 minutes to load a page -- at first I thought my office network 
 screwed
 up again, but now I'm at home and it's still like that.


 T

Fully conform. The server replies to slow: sometimes it open reference pages quickly, sometimes with considerable and inappropriate delay. Forum also doesn't work quite well always. By some reason its splits topics, like this one. Some time ago it could go hang in endless loop while posting messages. Now the situation is better - data is transferred to the server but delay is also inappropriate long.

The problem is still happening. Very slow at times, but also fast at other times. I was also noticing a number of topics are being broken up into spearate topics with same title. --rt
Oct 26 2012
parent "David Nadlinger" <see klickverbot.at> writes:
On Friday, 26 October 2012 at 22:59:41 UTC, Rob T wrote:
 On Friday, 26 October 2012 at 15:17:34 UTC, Maxim Fomin wrote:
 Fully conform. The server replies to slow: sometimes it open 
 reference pages quickly, sometimes with considerable and 
 inappropriate delay.

 Forum also doesn't work quite well always. By some reason its 
 splits topics, like this one. Some time ago it could go hang 
 in endless loop while posting messages. Now the situation is 
 better - data is transferred to the server but delay is also 
 inappropriate long.

The problem is still happening. Very slow at times, but also fast at other times. I was also noticing a number of topics are being broken up into spearate topics with same title.

This is probably not a forum.dlang.org bug, but a consequence of people using a broken client to reply which doesn't correctly set the threading-related headers. Still, it might be a good idea to look into heuristics to detect such mishaps, as it definitely looks very odd on the web interface. David
Oct 27 2012