www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 9824] New: Emplace is broken

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=9824

           Summary: Emplace is broken
           Product: D
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: ASSIGNED
          Keywords: wrong-code
          Severity: major
          Priority: P2
         Component: Phobos
        AssignedTo: monarchdodra gmail.com
        ReportedBy: monarchdodra gmail.com


--- Comment #0 from monarchdodra gmail.com 2013-03-28 04:30:01 PDT ---
Filing this because apparently it hasn't been filed yet.

Amongst others:
- Calls elaborate opAssign
- Fails on objects with disabled opAssign
- Fails to pre-blit T.init when using opAssign
- Fails on no-arg static arrays
- Fails to build from arg with alias this
- Doesn't always call the right construction scheme
- Calls static opCall

Proposed fix:
https://github.com/D-Programming-Language/phobos/pull/1082/files

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Mar 28 2013
parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=9824


David Nadlinger <code klickverbot.at> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |RESOLVED
                 CC|                            |code klickverbot.at
         Resolution|                            |FIXED


--- Comment #1 from David Nadlinger <code klickverbot.at> 2013-08-28 01:41:35
PDT ---
https://github.com/D-Programming-Language/phobos/commit/40c6760019d5fb8aee4c317f5d86881fdd2d6cd8

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Aug 28 2013