www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 9509] New: std.stdio fails to import with specific dmd command-line options

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=9509

           Summary: std.stdio fails to import with specific dmd
                    command-line options
           Product: D
           Version: D2
          Platform: x86_64
        OS/Version: Mac OS X
            Status: NEW
          Severity: normal
          Priority: P2
         Component: DMD
        AssignedTo: nobody puremagic.com
        ReportedBy: arthur itssomething.ca


--- Comment #0 from Arthur Castonguay <arthur itssomething.ca> 2013-02-14
07:05:30 PST ---
Trivial program:

import std.stdio;
void main() {
   writeln("Hello");
}

On the latest 2.061 MacOS dmd release (I installed via the DMD installer), if I
attempt to compile this with options: 

   -O -inline -noboundscheck -release

I get an error (sadly, I don't have it handy at the moment) from the std.stdio
import.  It's something about feof and eof and one not being callable from the
user due to one of them being pure.

If I remove the "-inline" option, all is well.  It tried various combinations
of the aforementioned options but all need to be present to make the issue
manifest.

If there's more information required, do yell.  I'll update the issue with the
exact error message when I'm back in front of my Mac.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Feb 14 2013
parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=9509


Arthur Castonguay <arthur itssomething.ca> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |DUPLICATE


--- Comment #1 from Arthur Castonguay <arthur itssomething.ca> 2013-02-15
03:13:41 PST ---
Issue was do to me installing a newer version and the installer didn't tidy up
what was there first.   Removing and reinstalling the latest version has this
issue gone.

*** This issue has been marked as a duplicate of issue 9510 ***

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Feb 15 2013