www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 3649] New: Socket not configured for work.

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649

           Summary: Socket not configured for work.
           Product: D
           Version: future
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: Phobos
        AssignedTo: nobody puremagic.com
        ReportedBy: 4ybaka gmail.com


--- Comment #0 from Dmitriy <4ybaka gmail.com> 2009-12-25 23:36:17 MSK ---
Created an attachment (id=534)
Test code

I compile and run code as in attachment with dmd 2.037 under linux and always
get number of sent bytes n=-1 and local address 0.0.0.0:0. But when I use dmd
1.051 (on linux) all works good: n=45 and local address 192.168.0.100:37563.
Also I check it under Windows with dmd 2.036 and all works.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Dec 25 2009
next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


Dmitriy Nesterov <4ybaka gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|major                       |normal


-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Dec 25 2009
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


iorlas <denis.tomilin gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |denis.tomilin gmail.com


--- Comment #1 from iorlas <denis.tomilin gmail.com> 2010-01-06 07:42:04 PST ---
Similar problem. Digital Mars D Compiler v2.038. Ubuntu 9.10(almost pure).
With telnet all works perfectly.
I'll add test code and strace-dump into attachments.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649



--- Comment #2 from iorlas <denis.tomilin gmail.com> 2010-01-06 07:44:30 PST ---
Created an attachment (id=543)
Test-code 2. Modified example code from some resources.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649



--- Comment #3 from iorlas <denis.tomilin gmail.com> 2010-01-06 07:47:49 PST ---
Created an attachment (id=544)
Full "strace" log from TestCode2 with "ya.ru index" arguments

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


iorlas <denis.tomilin gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|normal                      |critical


--- Comment #4 from iorlas <denis.tomilin gmail.com> 2010-01-06 08:29:56 PST ---
In 2.039 too. My 2 friends have similar problem.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


iorlas <denis.tomilin gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Priority|P2                          |P1


--- Comment #5 from iorlas <denis.tomilin gmail.com> 2010-01-06 09:15:41 PST ---
Tested on gentoo, fedora, debian and mops-linux. One result =/

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


iorlas <denis.tomilin gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|critical                    |blocker


-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649



--- Comment #6 from Alexander Suhoverhov <cy ngs.ru> 2010-01-06 10:17:03 PST ---
Created an attachment (id=545)
strace dump for running Test-code 2 with "ya.ru index"

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jan 06 2010
prev sibling next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


Andrey <bigasoft gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bigasoft gmail.com


--- Comment #7 from Andrey <bigasoft gmail.com> 2010-02-05 15:37:09 PST ---
This bug is duplicate of #2835.

The problem is caused by missing sin.sin_family initialization.
Please apply the fix suggested in bug #2835.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Feb 05 2010
prev sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3649


iorlas <denis.tomilin gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |DUPLICATE


--- Comment #8 from iorlas <denis.tomilin gmail.com> 2010-02-05 15:46:27 PST ---
(In reply to comment #7)
 This bug is duplicate of #2835.
 
 The problem is caused by missing sin.sin_family initialization.
 Please apply the fix suggested in bug #2835.

Great. Now waiting for fixing in repo... *** This issue has been marked as a duplicate of issue 2835 *** -- Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email ------- You are receiving this mail because: -------
Feb 05 2010