www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 3114] New: optlink failing on multicore machines

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3114

           Summary: optlink failing on multicore machines
           Product: D
           Version: unspecified
          Platform: Other
        OS/Version: Windows
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Optlink
        AssignedTo: nobody puremagic.com
        ReportedBy: bugzilla digitalmars.com


Optlink simply doesn't work on multicore. The multithreading code in it was
developed for a single core machine, and multicore is different.

I was able to fix it by running the command:

   imagecfg -a 0x1 \dm\bin\link.exe

imagecfg.exe is downloadable from the internet. This command patches the
executable so it only runs on one core.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jun 30 2009
parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=3114


Walter Bright <bugzilla digitalmars.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #1 from Walter Bright <bugzilla digitalmars.com>  2009-07-09
02:52:12 PDT ---
Fixed dmd 1.046 and 2.031

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jul 09 2009