www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 2752] New: std.xml does not encode CData correctly

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2752

           Summary: std.xml does not encode CData correctly
           Product: D
           Version: 2.025
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Phobos
        AssignedTo: bugzilla digitalmars.com
        ReportedBy: ben+dmars bagi.us


The xml module does not return the correct string representation of a CData
section. It returns "<[CDATA[" instead of "<![CDATA[".


-- 
Mar 21 2009
next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2752





------- Comment #1 from ben+dmars bagi.us  2009-03-21 10:07 -------
Created an attachment (id=293)
 --> (http://d.puremagic.com/issues/attachment.cgi?id=293&action=view)
Return correct representation of CData section


-- 
Mar 21 2009
prev sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2752


bugzilla digitalmars.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




------- Comment #2 from bugzilla digitalmars.com  2009-04-01 13:56 -------
Fixed DMD 2.027


-- 
Apr 01 2009