www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 2271] New: foreach over tuple regression

reply d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2271

           Summary: foreach over tuple regression
           Product: D
           Version: 1.033
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: regression
          Priority: P2
         Component: DMD
        AssignedTo: bugzilla digitalmars.com
        ReportedBy: tomas famolsen.dk


there is a regression for foreach on a tuple:

struct test {
  int foo;
  float bar;
}
void main() {
  test t;
  pragma(msg, typeof(t.tupleof).stringof);
  foreach (entry; t.tupleof) {
    pragma(msg, typeof(entry).stringof);
  }
}

with DMD 1.024 the output is correct:

(int, float)
int
float

However, with DMD 1.033 it's not:

(int, float)
int
int

I don't have any versions between if someone does, please check for earlier
versions :)


-- 
Aug 06 2008
next sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2271


Jarrett Billingsley <jarrett.billingsley gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |jarrett.billingsley gmail.c
                   |                            |om




--- Comment #1 from Jarrett Billingsley <jarrett.billingsley gmail.com> 
2009-07-06 14:28:44 PDT ---
This works fine in 1.039.  Can anyone else confirm?

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jul 06 2009
prev sibling parent d-bugmail puremagic.com writes:
http://d.puremagic.com/issues/show_bug.cgi?id=2271


Don <clugdbug yahoo.com.au> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
                 CC|                            |clugdbug yahoo.com.au
         Resolution|                            |FIXED




--- Comment #2 from Don <clugdbug yahoo.com.au>  2009-07-07 07:51:16 PDT ---
Confirmed fixed on Windows also.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Jul 07 2009