www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 18308] New: __VERSION__ insufficient; should also have

https://issues.dlang.org/show_bug.cgi?id=18308

          Issue ID: 18308
           Summary: __VERSION__ insufficient; should also have
                    __VERSION_MINOR__ and __VERSION_PATCH__ (eg 2.078.1)
           Product: D
           Version: D2
          Hardware: x86
                OS: Mac OS X
            Status: NEW
          Severity: normal
          Priority: P1
         Component: dmd
          Assignee: nobody puremagic.com
          Reporter: timothee.cour2 gmail.com

__VERSION__ insufficient; should also have __VERSION_MINOR__ and
__VERSION_PATCH__ (eg 2.078.1)

or simply: __VERSION_FULLY_QUALIFIED__ for 2.078.1 and 1.7.0

also, how do we get __VERSION_LDC__ ? eg for ldc 1.7.0 ?

--
Jan 26