www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 17999] New: UCRTVersion not properly set for Visual Studio

https://issues.dlang.org/show_bug.cgi?id=17999

          Issue ID: 17999
           Summary: UCRTVersion not properly set for Visual Studio
                    Community 2017
           Product: D
           Version: D2
          Hardware: x86_64
                OS: Windows
            Status: NEW
          Severity: major
          Priority: P1
         Component: installer
          Assignee: nobody puremagic.com
          Reporter: Bastiaan Veelo.net

When Visual Studio Community is the only version present on Windows 10, with
the minimal set of options that satisfies the dmd installer
(https://wiki.dlang.org/File:Visual_Studio_Installer.png) then dmd -m64 will
fail to link:
LINK : fatal error LNK1104: cannot open file 'libucrt.lib'
Error: linker exited with status 1104

The problem goes away after changing UCRTVersion in
C:\D\dmd2\windows\bin\sc.ini:

;UCRTVersion=winv6.3
UCRTVersion=10.0.10240.0


(Fresh dmd install.)

--
Nov 21