www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 17565] New: Rename theAllocator to threadAllocator

https://issues.dlang.org/show_bug.cgi?id=17565

          Issue ID: 17565
           Summary: Rename theAllocator to threadAllocator
           Product: D
           Version: D2
          Hardware: All
                OS: All
            Status: NEW
          Severity: enhancement
          Priority: P1
         Component: phobos
          Assignee: nobody puremagic.com
          Reporter: sludwig outerproduct.org

The current name doesn't convey the message that this is a thread-local
allocator. The relation to processAllocator also isn't quite clear. The private
variable that backs theAllocator is already named _threadAllocator and doing
the same for the accessor property is arguably the most logical choice.

--
Jun 28