www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.bugs - [Issue 17118] New: [REG 2.074a] iasm64.d in test suite with with -g

https://issues.dlang.org/show_bug.cgi?id=17118

          Issue ID: 17118
           Summary: [REG 2.074a] iasm64.d in test suite with with -g
                    reveals a regression
           Product: D
           Version: D2
          Hardware: x86_64
                OS: Linux
            Status: NEW
          Severity: regression
          Priority: P1
         Component: dmd
          Assignee: nobody puremagic.com
          Reporter: b2.temp gmx.com

Related to the newCTFE engine:

IRC:
---
<uplink|dmd> DotBatch, alphaglosined or someone else
[10:58] <uplink|dmd> please report that there are issues with iasm then
compiled with -g and a ~master dmd
[10:58] <uplink|dmd> this is a serious regression
[10:59] <DotBatch> I'd take the token but I'd like to verify before. That's why
I tried to  build a few minutes ago
[10:59] <DotBatch> eg. a small program to reproduce the issue
[11:00] <uplink|dmd> iasm64.d from the test-suite should be enough
[11:00] <uplink|dmd> this something only walter can fix efficiently I think
[11:00] <DotBatch> But it should be visible from the autotester then,
everything should becomes red in the next hours
[11:00] --> markos_ (~markos 62.74.8.235) a rejoint ce canal.
[11:00] <uplink|dmd> no
[11:01] <uplink|dmd> because dmd does not compile with -g 
[11:01] <uplink|dmd> and the auto-tester does not compile dmd with the freshly
compiled dmd
[11:01] <-- aermicioi (~aermicioi serv2.fcim.utm.md) a quitté ce serveur (Ping
timeout: 240 seconds).
[11:01] <uplink|dmd> it will only show up on travis
[11:01] <uplink|dmd> and only if someone tests it with -g
---

You should see the problem by running the test suite with the -g flag.

--
Jan 24