www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.announce - rulesPlayer 0.84

reply bobef <be lessequal_dontspam.com> writes:
http://www.dsource.org/projects/rulesplayer

some nice new stuff and some bug fixes
only one major problem is left - playing internet files
i have the feeling i've broken something though...
Dec 06 2006
next sibling parent reply clayasaurus <clayasaurus gmail.com> writes:
bobef wrote:
 http://www.dsource.org/projects/rulesplayer
 
 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

You should definitely advertise this more, as I think it is possibly the best media player option for windows. :) Make sure to post the digg links here too. http://www.digitalmars.com/d/howto-promote.html ~ Clay
Dec 06 2006
next sibling parent reply bobef <be lessequal_dontspam.com> writes:
clayasaurus wrote:
 bobef wrote:
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

You should definitely advertise this more, as I think it is possibly the best media player option for windows. :) Make sure to post the digg links here too. http://www.digitalmars.com/d/howto-promote.html ~ Clay

Thats where the name comes from ;) Yeah sure I also think it is the best, but it is kind of geeky so I don't think the typical windows user will like it...
Dec 06 2006
parent clayasaurus <clayasaurus gmail.com> writes:
bobef wrote:
 clayasaurus wrote:
 bobef wrote:
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

You should definitely advertise this more, as I think it is possibly the best media player option for windows. :) Make sure to post the digg links here too. http://www.digitalmars.com/d/howto-promote.html ~ Clay

Thats where the name comes from ;) Yeah sure I also think it is the best, but it is kind of geeky so I don't think the typical windows user will like it...

Yea, well the Internet is full of geeks and I'm sure some people will find it useful.
Dec 07 2006
prev sibling parent reply Max Bolingbroke <"batterseapower{no" sp4/\\/\\}hotmail.com> writes:
clayasaurus wrote:
 bobef wrote:
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

You should definitely advertise this more, as I think it is possibly the best media player option for windows. :) Make sure to post the digg links here too. http://www.digitalmars.com/d/howto-promote.html

I agree, this is a very nice frontend! I had been looking for an elegant alternative to VLC (I can't stand its interface, and as you say, the subtitles are horrendous): this looks to fit the bill perfectly! Thanks a lot! However, I'm sorry to report I have the same problem as Bill Baxter with the brightness. Also, an irritation is that subs are about twice as fast as they are in VLC, so they are over before the character stops speaking (though they start at the right time): I assume I can tweak this via a mplayer option, but I can't see one in the man page.. do you have any thoughts? I'm also having a problem where some subtitles that are shown in VLC are missed in rulesPlayer: specifically chapter titles in a series of videos. I think this occurs because there is also text being shown at the same time like "Episode 35" (appearing above chapter titles on the screen), and subtitles after the first are ignored. However, this is fine for most video, where only one person speaks at a time. Thanks again for this very nice player :-) Max
Dec 07 2006
parent reply bobef <be lessequal_dontspam.com> writes:
Max Bolingbroke wrote:
 clayasaurus wrote:
 bobef wrote:
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

You should definitely advertise this more, as I think it is possibly the best media player option for windows. :) Make sure to post the digg links here too. http://www.digitalmars.com/d/howto-promote.html

I agree, this is a very nice frontend! I had been looking for an elegant alternative to VLC (I can't stand its interface, and as you say, the subtitles are horrendous): this looks to fit the bill perfectly! Thanks a lot! However, I'm sorry to report I have the same problem as Bill Baxter with the brightness. Also, an irritation is that subs are about twice as fast as they are in VLC, so they are over before the character stops speaking (though they start at the right time): I assume I can tweak this via a mplayer option, but I can't see one in the man page.. do you have any thoughts?

About the brightness I always reply the same but nobody tells me if it helps so I will have to repeat it again :) "Yeah many people are complaining about this. I still believe it has to do with the overlay color corrections of your video, but who knows. If someone get to the bottom of this please let me know, cause there is no such thing for me so I have no idea how to fix it... "
 
 I'm also having a problem where some subtitles that are shown in VLC are 
 missed in rulesPlayer: specifically chapter titles in a series of 
 videos. I think this occurs because there is also text being shown at 
 the same time like "Episode 35" (appearing above chapter titles on the 
 screen), and subtitles after the first are ignored. However, this is 
 fine for most video, where only one person speaks at a time.
 

I also experienced problems with some subtitles (not showing colors for examples) I think MPlayer don't support some tags in some type of subtitles... Maybe this is the source of your problem too. Sorry I can't be more helpful... Try the MPlayer docs too. There is info how to pass more parameters to mplayer in the faq on http://www.dsource.org/projects/rulesplayer .
 Thanks again for this very nice player :-)
 
 Max

Dec 07 2006
parent reply =?UTF-8?B?SnVsaW8gQ8Opc2FyIENhcnJhc2NhbCBVcnF1aWpv?= writes:
bobef wrote:
 I also experienced problems with some subtitles (not showing colors for 
 examples) I think MPlayer don't support some tags in some type of 
 subtitles... Maybe this is the source of your problem too. Sorry I can't 
 be more helpful... Try the MPlayer docs too. There is info how to pass 
 more parameters to mplayer in the faq on 
 http://www.dsource.org/projects/rulesplayer .
 
 Thanks again for this very nice player :-)

 Max


You need to activate SSA/ASS subtitles with the -ass option to get fonts, colors and different positions for subtitles.
Dec 07 2006
parent reply bobef <be lessequal_dontspam.com> writes:
Julio César Carrascal Urquijo wrote:
 bobef wrote:
 I also experienced problems with some subtitles (not showing colors 
 for examples) I think MPlayer don't support some tags in some type of 
 subtitles... Maybe this is the source of your problem too. Sorry I 
 can't be more helpful... Try the MPlayer docs too. There is info how 
 to pass more parameters to mplayer in the faq on 
 http://www.dsource.org/projects/rulesplayer .

 Thanks again for this very nice player :-)

 Max


You need to activate SSA/ASS subtitles with the -ass option to get fonts, colors and different positions for subtitles.

Thanks. I will take a look and make it default eventually...
Dec 07 2006
parent reply Max Bolingbroke <"batterseapower{no" sp4/\\/\\}hotmail.com> writes:
bobef wrote:
 Julio César Carrascal Urquijo wrote:
 bobef wrote:
 I also experienced problems with some subtitles (not showing colors 
 for examples) I think MPlayer don't support some tags in some type of 
 subtitles... Maybe this is the source of your problem too. Sorry I 
 can't be more helpful... Try the MPlayer docs too. There is info how 
 to pass more parameters to mplayer in the faq on 
 http://www.dsource.org/projects/rulesplayer .

 Thanks again for this very nice player :-)

 Max


You need to activate SSA/ASS subtitles with the -ass option to get fonts, colors and different positions for subtitles.

Thanks. I will take a look and make it default eventually...

Yeah, this fixes all my problems :-). Weird, since the subtitles I was using are in SSA format I would have expected this to just happen. Anyway, thanks a lot Julio!
Dec 07 2006
parent =?UTF-8?B?SnVsaW8gQ8Opc2FyIENhcnJhc2NhbCBVcnF1aWpv?= writes:
Max Bolingbroke wrote:
 Yeah, this fixes all my problems :-). Weird, since the subtitles I was 
 using are in SSA format I would have expected this to just happen. 
 Anyway, thanks a lot Julio!

Cool. I find MPlayer to be the best player ever written for Windows and Linux but the defaults are somewhat strange sometimes. I guess it is disabled by default for performance reasons but the option should be more visible in the documentation. Other commands you should take a look at are: -sub-fuzziness 2 Loads all subtitles in the folder and you can select which one to display using the J key. Useful if you have English and Spanish subtitles in the same folder. -vf screenshot To allow taking screenshots of the movie (With the S key). Otherwise the screenshot will only show the video overlay. -subfont-text-scale 5 (default subtitles) -ffactor 1 (For -ass) I find the default font size a too big. This reduces the scaling factor a bit. -idx Re-indexes a damaged movie to allow scrolling.
Dec 07 2006
prev sibling next sibling parent reply Bill Baxter <dnewsgroup billbaxter.com> writes:
bobef wrote:
 http://www.dsource.org/projects/rulesplayer
 
 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

Not bad. Lightweight, no crazy, hard-to-comprehend 'skinz', and fast startup. The default brightness setting looks to be off thought. If brightness is turned down to zero the output looks like other media players. The default makes everything look all white-washed. One small annoyance -- with a dual monitor setup the window starts up straddling the two screens. At least it would be nice if rulesplayer would remember where it was between runs. --bb
Dec 06 2006
next sibling parent Daniel Keep <daniel.keep+lists gmail.com> writes:
Bill Baxter wrote:
 bobef wrote:
 
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

Not bad. Lightweight, no crazy, hard-to-comprehend 'skinz', and fast startup. The default brightness setting looks to be off thought. If brightness is turned down to zero the output looks like other media players. The default makes everything look all white-washed. One small annoyance -- with a dual monitor setup the window starts up straddling the two screens. At least it would be nice if rulesplayer would remember where it was between runs. --bb

I haven't gotten the download yet, but I think I know what the issue is. If you're going to start up a window "centered" then you need to place it in the center of the primary monitor only. I know there's an API to get the extents of the system monitors. That, or you can let Windows do the initial positioning itself. The upshot of this is that Windows will automatically position the window on the same monitor as the window you launched the program from. When in doubt, let the system figure it out :3 -- Daniel
Dec 06 2006
prev sibling parent bobef <be lessequal_dontspam.com> writes:
Bill Baxter wrote:
 bobef wrote:
 http://www.dsource.org/projects/rulesplayer

 some nice new stuff and some bug fixes
 only one major problem is left - playing internet files
 i have the feeling i've broken something though...

Not bad. Lightweight, no crazy, hard-to-comprehend 'skinz', and fast startup. The default brightness setting looks to be off thought. If brightness is turned down to zero the output looks like other media players. The default makes everything look all white-washed.

Yeah many people are complaining about this. I still believe it has to do with the overlay color corrections of your video, but who knows. If someone get to the bottom of this please let me know, cause there is no such thing for me so I have no idea how to fix it...
 One small annoyance -- with a dual monitor setup the window starts up 
 straddling the two screens.  At least it would be nice if rulesplayer 
 would remember where it was between runs.
 

Will fix that.
Dec 06 2006
prev sibling next sibling parent reply "nobody_" <spam spam.spam> writes:
Probably nothing, but AVG says there's a trojan in the installer:
PSW.Lineage
Dec 07 2006
parent reply renoX <renosky free.fr> writes:
nobody_ a crit :
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage

Curious: on my PC, AVG didn't complain. I like this player: very simple to use. I have some small annoyances with it: - There is no play/pause when I click on the window. I've tried adding in config.kfg bind mouse1 " pause" without success. - When I pause with the spacebar, it 'stay paused': when I press the spacebar again to make it play again, it plays just a few frames and then it pause again. - it cannot open files with an accent in the filename on my PC (I've opened a topic on the subject in the forum). But it's still quite good: very usable skin. renoX
Dec 08 2006
next sibling parent reply bobef <be lessequal_dontspam.com> writes:
renoX wrote:
 nobody_ a crit :
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage

Curious: on my PC, AVG didn't complain. I like this player: very simple to use. I have some small annoyances with it: - There is no play/pause when I click on the window. I've tried adding in config.kfg bind mouse1 " pause" without success. - When I pause with the spacebar, it 'stay paused': when I press the spacebar again to make it play again, it plays just a few frames and then it pause again. - it cannot open files with an accent in the filename on my PC (I've opened a topic on the subject in the forum). But it's still quite good: very usable skin. renoX

Hmm... Weird... Just checked and you are right... Maybe I broke something cause it was working a while ago. I will fix it...
Dec 09 2006
parent reply bobef <be lessequal_dontspam.com> writes:
bobef wrote:
 renoX wrote:
 nobody_ a crit :
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage

Curious: on my PC, AVG didn't complain. I like this player: very simple to use. I have some small annoyances with it: - There is no play/pause when I click on the window. I've tried adding in config.kfg bind mouse1 " pause" without success. - When I pause with the spacebar, it 'stay paused': when I press the spacebar again to make it play again, it plays just a few frames and then it pause again. - it cannot open files with an accent in the filename on my PC (I've opened a topic on the subject in the forum). But it's still quite good: very usable skin. renoX

Hmm... Weird... Just checked and you are right... Maybe I broke something cause it was working a while ago. I will fix it...

If you your binding in the config while player is running it will be replaced when you quit, so type "bind mouse1 pause" (w/o quotes) in the console. It will fix the mouse1 problem.
Dec 09 2006
parent reply renoX <renosky free.fr> writes:
bobef a crit :
 bobef wrote:
 renoX wrote:
 nobody_ a crit :
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage

Curious: on my PC, AVG didn't complain. I like this player: very simple to use. I have some small annoyances with it: - There is no play/pause when I click on the window. I've tried adding in config.kfg bind mouse1 " pause" without success. - When I pause with the spacebar, it 'stay paused': when I press the spacebar again to make it play again, it plays just a few frames and then it pause again. - it cannot open files with an accent in the filename on my PC (I've opened a topic on the subject in the forum). But it's still quite good: very usable skin. renoX

Hmm... Weird... Just checked and you are right... Maybe I broke something cause it was working a while ago. I will fix it...

If you your binding in the config while player is running it will be replaced when you quit, so type "bind mouse1 pause" (w/o quotes) in the console. It will fix the mouse1 problem.

Thanks for your answer: now mouse1 indeed pause the screen. I don't know why the first time it didn't work: I did modify config.kfg while rulesPlayer was off, maybe it was the quotes around pause, but this seems strange as all the other entries have quotes, and now the entry have also quotes around pause (added by the player at exit I think), oh well, it's working now, thanks, maybe you could change the default configuration file in the package? Now that mouse1 works, I don't care much about the 'spacebar stay paused' bug, your player just became my default player, thanks! Funnily there is another bug opposite to the 'stay paused with the spacebar bug': when you're in pause mode and you use the left arrow to go back 5s, it will change in play mode: in my opinion, it should keep the current mode: play mode if it used to play, pause mode if it was in pause mode.. Your player is better than mediaplayer classic as the user can easily adjust the colors, but worse as he cannot zoom easily like with mediaplayer classic. For the bugs, do you prefer, entries in the forum or in the ticket system? Regards, renoX
Dec 09 2006
parent bobef <be lessequal_dontspam.com> writes:
 
 Thanks for your answer: now mouse1 indeed pause the screen.
 I don't know why the first time it didn't work: I did modify config.kfg 
 while rulesPlayer was off, maybe it was the quotes around  pause, but 
 this seems strange as all the other entries have quotes, and now the 
 entry have also quotes around  pause (added by the player at exit I 
 think), oh well, it's working now, thanks, maybe you could change the 
 default configuration file in the package?
 

It is in the default config. I investigated and it was a typo that was causing the problem (mouse1dbd instead of mouse1dbl)... Quotes are used as on the command line, i.e. take bind for example. It is taking 2 parameters - one for the key and one for the command but if you want command that is not just "pause" but say "yell HELLO!" you have to write "bind x yell HELLO!" which becomes 3 parameters so you quote the yell command and everything in the quotes is parameter 2 like this "bind x "yell HELLo!"", so when you press x you will see a message box (useless really:)
 Now that mouse1 works, I don't care much about the 'spacebar stay 
 paused' bug, your player just became my default player, thanks!
 
 Funnily there is another bug opposite to the 'stay paused with the 
 spacebar bug': when you're in pause mode and you use the left arrow to 
 go back 5s, it will change in play mode: in my opinion, it should keep 
 the current mode: play mode if it used to play, pause mode if it was in 
 pause mode..
 

Yeah I think so too but this is up to MPlayer, and it isn't working as documented on this matter...
 Your player is better than mediaplayer classic as the user can easily 
 adjust the colors, but worse as he cannot zoom easily like with 
 mediaplayer classic.
 

For now you can just resize the window to the size you want... I will think about zooming...
 For the bugs, do you prefer, entries in the forum or in the ticket system?
 

Please use the forum, I added few entries to the ticket system but it seems useless now because I am the only developer on the project... Thank you for your interest in my player. I will answer in the forum but currently I can't open dsource.org... -bobef
Dec 09 2006
prev sibling parent reply "nobody_" <spam spam.spam> writes:
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage

Curious: on my PC, AVG didn't complain.

search. I'll check it out.
Dec 09 2006
parent reply renoX <renosky free.fr> writes:
nobody_ a crit :
 Probably nothing, but AVG says there's a trojan in the installer:
 PSW.Lineage


search. I'll check it out.

For the record, I also have AVG 7.5, the free edition (with the latest virus/spyware definitions). I've checked again rulessetup.exe and it is clean from my AVG view (both antivirus and antispyware).. And as I had to reinstall my PC two weeks ago (disk failure), I'm reasonably sure that my PC doesn't have virus. renoX
Dec 09 2006
parent "nobody_" <spam spam.spam> writes:
Ay, rechecked it.. no more virus to reports.
Must have been a wrong definition file or something.

 For the record, I also have AVG 7.5, the free edition (with the latest 
 virus/spyware definitions).

 I've checked again rulessetup.exe and it is clean from my AVG view (both 
 antivirus and antispyware)..
 And as I had to reinstall my PC two weeks ago (disk failure), I'm 
 reasonably sure that my PC doesn't have virus.

 renoX 

Dec 09 2006
prev sibling parent bobef <be lessequal_dontspam.com> writes:
http://www.dsource.org/projects/rulesplayer

bug fixes and improvements, some new stuff, some more documentation (in 
readme.txt), better todo list
i hope this version is stable

call for help - two major problems are left that i'm currently unable to 
solve myself and now only they stop me from calling the player rc1
so if you have experience with MPlayer/DWT and you think you can and 
want to help me...

1) internet streams are not working
2) non-english characters support is missing

if you wish to help please use the dsource forum
Dec 13 2006