www.digitalmars.com         C & C++   DMDScript  

digitalmars.D.announce - Release vibe.d 0.7.31

reply =?UTF-8?Q?S=c3=b6nke_Ludwig?= <sludwig outerproduct.org> writes:
This release is a backport release of the smaller changes that go into 
0.8.0. The 0.7.x branch will continue to be maintained for a short 
while, but only bug fixes will be included from now on. Applications 
should switch to the 0.8.x branch as soon as possible.

Main changes over 0.7.30:

   - Compiles on the latest DMD version (2.068.x-2.072.0)
   - Introduces a number of forward compatibility declarations for the
     0.8.0 branch and vibe-core
   - The HTTP server received various improvements
   - All changes: https://vibed.org/blog/posts/vibe-release-0.7.31

DUB package:
https://code.dlang.org/packages/vibe-d/0.7.31
Apr 10
next sibling parent reply Martin Nowak <code dawg.eu> writes:
Thanks

On Monday, 10 April 2017 at 20:48:34 UTC, Sönke Ludwig wrote:
   - Compiles on the latest DMD version (2.068.x-2.072.0)
2.068.x-2.074.0, that is
Apr 12
parent =?UTF-8?Q?S=c3=b6nke_Ludwig?= <sludwig outerproduct.org> writes:
Am 12.04.2017 um 12:03 schrieb Martin Nowak:
 Thanks

 On Monday, 10 April 2017 at 20:48:34 UTC, Sönke Ludwig wrote:
   - Compiles on the latest DMD version (2.068.x-2.072.0)
2.068.x-2.074.0, that is
True, thanks for the notice!
Apr 13
prev sibling parent reply "Nick Sabalausky (Abscissa)" <SeeWebsiteToContactMe semitwist.com> writes:
On 04/10/2017 04:48 PM, Sönke Ludwig wrote:
 The 0.7.x branch will continue to be maintained for a short
 while, but only bug fixes will be included from now on. Applications
 should switch to the 0.8.x branch as soon as possible.
If a library depends on vibe, but wants to allow its users to use either 0.7.x or 0.8.x, is there a recommended way to do that? Ie: https://github.com/mysql-d/mysql-native/issues/99
Apr 12
parent =?UTF-8?Q?S=c3=b6nke_Ludwig?= <sludwig outerproduct.org> writes:
Am 12.04.2017 um 20:29 schrieb Nick Sabalausky (Abscissa):
 On 04/10/2017 04:48 PM, Sönke Ludwig wrote:
 The 0.7.x branch will continue to be maintained for a short
 while, but only bug fixes will be included from now on. Applications
 should switch to the 0.8.x branch as soon as possible.
If a library depends on vibe, but wants to allow its users to use either 0.7.x or 0.8.x, is there a recommended way to do that? Ie: https://github.com/mysql-d/mysql-native/issues/99
I use ">=0.7.31 <0.9.0" in one of my projects for that purpose. Some kind of union operator would be nicer (e.g. "~>0.7.31 | ~>0.8.0"), but for all practical purposes I think it should be fine.
Apr 13