www.digitalmars.com         C & C++   DMDScript  

digitalmars.D - SPAM Captcha?

reply "Tyler Jameson Little" <beatgammit gmail.com> writes:
I just tried to post a reply to Dicebot on the announce subforum 
through the web ui and I got a reCAPTCHA (first time ever) and I 
could not pass the CAPTCHA, and I tried several times.

Did something change in the spam filter?

Has anyone else had problems with the reCAPTCHA? Is there 
something messed up with my account?

I have tried on Firefox and Chromium (Linux, no flash; FF has JS 
blocked for dlang.org). I don't know if I'll be able to reply to 
this ='(
Aug 26 2013
next sibling parent "Dicebot" <public dicebot.lv> writes:
On Monday, 26 August 2013 at 14:20:58 UTC, Tyler Jameson Little 
wrote:
 I just tried to post a reply to Dicebot on the announce 
 subforum through the web ui and I got a reCAPTCHA (first time 
 ever) and I could not pass the CAPTCHA, and I tried several 
 times.

 Did something change in the spam filter?

 Has anyone else had problems with the reCAPTCHA? Is there 
 something messed up with my account?

 I have tried on Firefox and Chromium (Linux, no flash; FF has 
 JS blocked for dlang.org). I don't know if I'll be able to 
 reply to this ='(

Ironically, I have also never been able to pass the spam filter. Once it triggers, only option is to wait expiration time (30min+) until posting without reCAPTCHA is allowed again :( But it has happened so rare that I kept forgetting to report it to CyberShadow.
Aug 26 2013
prev sibling next sibling parent "Craig Dillabaugh" <cdillaba cg.scs.carleton.ca> writes:
On Monday, 26 August 2013 at 14:31:06 UTC, Dicebot wrote:
 On Monday, 26 August 2013 at 14:20:58 UTC, Tyler Jameson Little 
 wrote:
 I just tried to post a reply to Dicebot on the announce 
 subforum through the web ui and I got a reCAPTCHA (first time 
 ever) and I could not pass the CAPTCHA, and I tried several 
 times.

 Did something change in the spam filter?

 Has anyone else had problems with the reCAPTCHA? Is there 
 something messed up with my account?

 I have tried on Firefox and Chromium (Linux, no flash; FF has 
 JS blocked for dlang.org). I don't know if I'll be able to 
 reply to this ='(

Ironically, I have also never been able to pass the spam filter. Once it triggers, only option is to wait expiration time (30min+) until posting without reCAPTCHA is allowed again :( But it has happened so rare that I kept forgetting to report it to CyberShadow.

This happens to me quite regularly. I seem to recall that there have been a few instances where I just kept trying and trying and finally got it to work, but I am not 100% sure. Other times I've just copied my post to the clipboard, gone back an started a new post and submitted that way. On occasion I've just given up.
Aug 26 2013
prev sibling next sibling parent "monarch_dodra" <monarchdodra gmail.com> writes:
On Monday, 26 August 2013 at 14:31:06 UTC, Dicebot wrote:
 On Monday, 26 August 2013 at 14:20:58 UTC, Tyler Jameson Little 
 wrote:
 I just tried to post a reply to Dicebot on the announce 
 subforum through the web ui and I got a reCAPTCHA (first time 
 ever) and I could not pass the CAPTCHA, and I tried several 
 times.

 Did something change in the spam filter?

 Has anyone else had problems with the reCAPTCHA? Is there 
 something messed up with my account?

 I have tried on Firefox and Chromium (Linux, no flash; FF has 
 JS blocked for dlang.org). I don't know if I'll be able to 
 reply to this ='(

Ironically, I have also never been able to pass the spam filter. Once it triggers, only option is to wait expiration time (30min+) until posting without reCAPTCHA is allowed again :( But it has happened so rare that I kept forgetting to report it to CyberShadow.

I get hit by it every time I post more than twice in less than a minute (happens every once in a while: When I reply to two posts, and hit send for both in a short amount of time). This raises a flag that I need to solve a captcha to continue. I have *never* been able to solve it. Worst yet, I usually can't post anything until it is solved, so I usually have to restart my browser and/or delete my cookies.
Aug 26 2013
prev sibling next sibling parent reply "Vladimir Panteleev" <vladimir thecybershadow.net> writes:
On Monday, 26 August 2013 at 14:20:58 UTC, Tyler Jameson Little 
wrote:
 I just tried to post a reply to Dicebot on the announce 
 subforum through the web ui and I got a reCAPTCHA (first time 
 ever) and I could not pass the CAPTCHA, and I tried several 
 times.

My bad. The duplicate submission detection feature interacted with the CAPTCHA code in a bad way, creating a bug where if you failed the first CAPTCHA, all your subsequent tries would also "fail" (it would redirect to the result of your first failure). You'd need to change something in your post to get around it. Should be fixed now.
Aug 26 2013
parent Walter Bright <newshound2 digitalmars.com> writes:
On 8/27/2013 5:45 AM, Vladimir Panteleev wrote:
 Judging by the logs, that seems to have been caused by some temporary network /
 server problems at StopForumSpam. The problems seemed to be constrained in the
 time period between 4 and 8 AM UTC today, so the problem should be gone by now.
 Let me know if it happens again.

Thanks for keeping on top of this! You da man.
Aug 27 2013
prev sibling next sibling parent "monarch_dodra" <monarchdodra gmail.com> writes:
On Monday, 26 August 2013 at 16:22:15 UTC, Vladimir Panteleev
wrote:
 On Monday, 26 August 2013 at 14:20:58 UTC, Tyler Jameson Little 
 wrote:
 I just tried to post a reply to Dicebot on the announce 
 subforum through the web ui and I got a reCAPTCHA (first time 
 ever) and I could not pass the CAPTCHA, and I tried several 
 times.

My bad. The duplicate submission detection feature interacted with the CAPTCHA code in a bad way, creating a bug where if you failed the first CAPTCHA, all your subsequent tries would also "fail" (it would redirect to the result of your first failure). You'd need to change something in your post to get around it. Should be fixed now.

I can solve them now, which is better than before I guess. On the other hand, I now have to resolve a captcha for every one of my posts :/
Aug 27 2013
prev sibling next sibling parent "Vladimir Panteleev" <vladimir thecybershadow.net> writes:
On Tuesday, 27 August 2013 at 07:49:04 UTC, monarch_dodra wrote:
 On the other hand, I now have to resolve a captcha for every one
 of my posts :/

Judging by the logs, that seems to have been caused by some temporary network / server problems at StopForumSpam. The problems seemed to be constrained in the time period between 4 and 8 AM UTC today, so the problem should be gone by now. Let me know if it happens again.
Aug 27 2013
prev sibling parent "monarch_dodra" <monarchdodra gmail.com> writes:
On Tuesday, 27 August 2013 at 12:45:32 UTC, Vladimir Panteleev
wrote:
 On Tuesday, 27 August 2013 at 07:49:04 UTC, monarch_dodra wrote:
 On the other hand, I now have to resolve a captcha for every 
 one
 of my posts :/

Judging by the logs, that seems to have been caused by some temporary network / server problems at StopForumSpam. The problems seemed to be constrained in the time period between 4 and 8 AM UTC today, so the problem should be gone by now. Let me know if it happens again.

Thanks. it actually stopped, so no more problems.
Aug 27 2013