www.digitalmars.com         C & C++   DMDScript  

c++.dos.32-bits - Build Problems

reply "Björn Sonntag" <pug1975 gmx.de> writes:
Hello NG,

i've some big problems with the DM C++ Compiler ... i have portted a project
from Watcom 11.X to DM. This Project uses the DosExtender.
Now when i build the Program in the final step following errors occurs :

cx.obj ..... Symbol Undefined __x386_start
cx.obj ..... Symbol Undefined __x386_data_16_alias
cx.obj ..... Symbol Undefined __x386_dbg_hook
cx.obj ..... Symbol Undefined __x32_link_in_x32_lib

sdx.lib ..... Symbol UnDefined __x386_memlock
sdx.lib ..... Symbol UnDefined __x386_memunlock

Can you help me ???
Thx

Bjoern
Jun 01 2004
parent reply "Walter" <newshound digitalmars.com> writes:
Those are defined in cx.obj and sdx.lib. cx.obj has to appear first in the
command to the linker.

"Björn Sonntag" <pug1975 gmx.de> wrote in message
news:c9i73m$1ddm$1 digitaldaemon.com...
 Hello NG,

 i've some big problems with the DM C++ Compiler ... i have portted a

 from Watcom 11.X to DM. This Project uses the DosExtender.
 Now when i build the Program in the final step following errors occurs :

 cx.obj ..... Symbol Undefined __x386_start
 cx.obj ..... Symbol Undefined __x386_data_16_alias
 cx.obj ..... Symbol Undefined __x386_dbg_hook
 cx.obj ..... Symbol Undefined __x32_link_in_x32_lib

 sdx.lib ..... Symbol UnDefined __x386_memlock
 sdx.lib ..... Symbol UnDefined __x386_memunlock

 Can you help me ???
 Thx

 Bjoern

Jun 01 2004
parent reply "Björn Sonntag" <pug1975 gmx.de> writes:
i have the dosextender ;-) i found the mistake ... i have forgotten to link
the x32.lib to the project ....

Now the project is built but i can't start it ... when i call it then
nothing happend.

Source :

#include <iostream.h>

void main(void)
{
    cout << "Hello World!" << endl;

}


OS : DOS 6.22 .... RAM 256 MB .... conv Mem : 487 kb .

config.sys :

device=c:\dos\himem.sys
rem device=c:\dos\emm386.exe /noems
BUFFERS=30
FILES=40
STACKS=9,256
LASTDRIVE=Z
dos=high,umb
SHELL=c:\COMMAND.COM c:\ /P /E:1024
rem devicehigh=C:\NET\ifshlp.sys


autoexec.bat :

echo off
PATH = c:\;c:\dos;c:\tools;c:\novell;c:\spc4
\dos\KEYB GR,,\dos\KEYBOARD.SYS
\dos\doskey
prompt $p$_$g

Thanks

bjoern
Jun 02 2004
parent "Walter" <newshound digitalmars.com> writes:
I have no clue. What exactly is the command you use to build and link? Also,
try using printf instead of iostream.

"Björn Sonntag" <pug1975 gmx.de> wrote in message
news:c9kgn0$1m4c$1 digitaldaemon.com...
 i have the dosextender ;-) i found the mistake ... i have forgotten to

 the x32.lib to the project ....

 Now the project is built but i can't start it ... when i call it then
 nothing happend.

 Source :

 #include <iostream.h>

 void main(void)
 {
     cout << "Hello World!" << endl;

 }


 OS : DOS 6.22 .... RAM 256 MB .... conv Mem : 487 kb .

 config.sys :

 device=c:\dos\himem.sys
 rem device=c:\dos\emm386.exe /noems
 BUFFERS=30
 FILES=40
 STACKS=9,256
 LASTDRIVE=Z
 dos=high,umb
 SHELL=c:\COMMAND.COM c:\ /P /E:1024
 rem devicehigh=C:\NET\ifshlp.sys


 autoexec.bat :

 echo off
 PATH = c:\;c:\dos;c:\tools;c:\novell;c:\spc4
 \dos\KEYB GR,,\dos\KEYBOARD.SYS
 \dos\doskey
 prompt $p$_$g

 Thanks

 bjoern

Jun 04 2004