www.digitalmars.com         C & C++   DMDScript  

c++.dos.16-bits - Zinc Application Framework

reply Daniel <Daniel_member pathlink.com> writes:
Hallo,

I'm in need to support an old product developped under
Borland C++ 4.5 using ZAF 4.11, which I just can't find anywhere.

An official license is no longer available.
I read an old thread on the Zinc Application Framework.

Does anybody know where to get 4.11.
I'm also willing to pay for a license.

Daniel
Mar 21 2003
parent reply "Javier Gutiérrez" <nikkho NOSPAM hotmail.com> writes:
    Windriver does not sell Zinc 4.x anymore.
    They give away version 5.3 for Desktop, and 6.0 for vxWorks.
    I own version 5.3 and althought is a lot more powerful than 4.2 it
requires MetaWindow library in order to support DOS, so the DOS executables
require some external dependencies of MetaWindow, while 4.x does not.
    I am also interested in getting Zinc 4.x so if you are able to find it
somewhere, please let me know.
    If you need to support DOS in 16 bit mode using Borland compilers, maybe
Zinc 3.0 is enought to you.
    I have 3.0 and 5.3 so, let me know if are interested.


"Daniel" <Daniel_member pathlink.com> escribió en el mensaje
news:b5f914$jq1$1 digitaldaemon.com...
 Hallo,

 I'm in need to support an old product developped under
 Borland C++ 4.5 using ZAF 4.11, which I just can't find anywhere.

 An official license is no longer available.
 I read an old thread on the Zinc Application Framework.

 Does anybody know where to get 4.11.
 I'm also willing to pay for a license.

 Daniel

Mar 23 2003
parent reply Daniel <Daniel_member pathlink.com> writes:
I already downloaded the 3.0 version from the ftp mentioned in
an older thread, but haven't tried yet if it works with my code.
As soon as I get 4.1, I'll let you know

In article <b5k7er$118g$1 digitaldaemon.com>, Javier Gutiérrez says...
    Windriver does not sell Zinc 4.x anymore.
    They give away version 5.3 for Desktop, and 6.0 for vxWorks.
    I own version 5.3 and althought is a lot more powerful than 4.2 it
requires MetaWindow library in order to support DOS, so the DOS executables
require some external dependencies of MetaWindow, while 4.x does not.
    I am also interested in getting Zinc 4.x so if you are able to find it
somewhere, please let me know.
    If you need to support DOS in 16 bit mode using Borland compilers, maybe
Zinc 3.0 is enought to you.
    I have 3.0 and 5.3 so, let me know if are interested.


"Daniel" <Daniel_member pathlink.com> escribió en el mensaje
news:b5f914$jq1$1 digitaldaemon.com...
 Hallo,

 I'm in need to support an old product developped under
 Borland C++ 4.5 using ZAF 4.11, which I just can't find anywhere.

 An official license is no longer available.
 I read an old thread on the Zinc Application Framework.

 Does anybody know where to get 4.11.
 I'm also willing to pay for a license.

 Daniel


Daniel
Mar 24 2003
parent "Javier Gutiérrez" <nikkho NOSPAM hotmail.com> writes:
    Hi Daniel,

    I have tried 3.0 with DigitalMars and with Borland C++ and no problems.
Only the Win 3.1 look, and no protected mode support.

    Version 5.3 is fair better.

    Please, let me know as soon as you get Zinc 4.x.



"Daniel" <Daniel_member pathlink.com> escribió en el mensaje
news:b5mrnn$2o1j$1 digitaldaemon.com...
 I already downloaded the 3.0 version from the ftp mentioned in
 an older thread, but haven't tried yet if it works with my code.
 As soon as I get 4.1, I'll let you know

 In article <b5k7er$118g$1 digitaldaemon.com>, Javier Gutiérrez says...
    Windriver does not sell Zinc 4.x anymore.
    They give away version 5.3 for Desktop, and 6.0 for vxWorks.
    I own version 5.3 and althought is a lot more powerful than 4.2 it
requires MetaWindow library in order to support DOS, so the DOS


require some external dependencies of MetaWindow, while 4.x does not.
    I am also interested in getting Zinc 4.x so if you are able to find


somewhere, please let me know.
    If you need to support DOS in 16 bit mode using Borland compilers,


Zinc 3.0 is enought to you.
    I have 3.0 and 5.3 so, let me know if are interested.


"Daniel" <Daniel_member pathlink.com> escribió en el mensaje
news:b5f914$jq1$1 digitaldaemon.com...
 Hallo,

 I'm in need to support an old product developped under
 Borland C++ 4.5 using ZAF 4.11, which I just can't find anywhere.

 An official license is no longer available.
 I read an old thread on the Zinc Application Framework.

 Does anybody know where to get 4.11.
 I'm also willing to pay for a license.

 Daniel


Daniel

Mar 24 2003