www.digitalmars.com         C & C++   DMDScript  

c++ - Re: MASM386

reply "Nic Tiger" <nictiger pt.comcor.ru> writes:
Hi,

Does anyone have or know where to find masm386?

I need it in order to compile RTL (DMC 8.27).
I cannot compile RTL ASM's with Masm 5.10 and Masm 6.15.

Any suggestions?

Looking forward for an answer,
        Nic Tiger.
Jun 19 2002
parent reply Jan Knepper <jan smartsoft.cc> writes:
I thought the newer compiler find masm 5.10 or masm 6.15 when it
can find it in the path...

Jan



Nic Tiger wrote:

 Hi,

 Does anyone have or know where to find masm386?

 I need it in order to compile RTL (DMC 8.27).
 I cannot compile RTL ASM's with Masm 5.10 and Masm 6.15.

 Any suggestions?

 Looking forward for an answer,
         Nic Tiger.

Jun 19 2002
parent reply "Nic Tiger" <nictiger pt.comcor.ru> writes:
I meant that I *have* both Masm 5.10 and Masm 6.15 (and 6.1), but RTL
sources doesn't compile with them, giving strange errors inside 'begcode'
macro.

Nic Tiger.

"Jan Knepper" <jan smartsoft.cc> wrote in message
news:3D10D500.141280D1 smartsoft.cc...
 I thought the newer compiler find masm 5.10 or masm 6.15 when it
 can find it in the path...

 Jan



 Nic Tiger wrote:

 Hi,

 Does anyone have or know where to find masm386?

 I need it in order to compile RTL (DMC 8.27).
 I cannot compile RTL ASM's with Masm 5.10 and Masm 6.15.

 Any suggestions?

 Looking forward for an answer,
         Nic Tiger.


Jun 19 2002
next sibling parent "Walter" <walter digitalmars.com> writes:
"Nic Tiger" <nictiger pt.comcor.ru> wrote in message
news:aeqkhc$2jq9$1 digitaldaemon.com...
 I meant that I *have* both Masm 5.10 and Masm 6.15 (and 6.1), but RTL
 sources doesn't compile with them, giving strange errors inside 'begcode'
 macro.

 Nic Tiger.

Microsoft constantly changed the masm language from assembler to assembler, making it most aggravating to rely on it. All I can suggest is trying to bash on begcode to try and get it to work with your masm.
Jun 19 2002
prev sibling parent Roland <rv ronetech.com> writes:
try TASM ?

It works well for me at least for home made code, not rtl.

roland


Nic Tiger a écrit :

 I meant that I *have* both Masm 5.10 and Masm 6.15 (and 6.1), but RTL
 sources doesn't compile with them, giving strange errors inside 'begcode'
 macro.

 Nic Tiger.

 "Jan Knepper" <jan smartsoft.cc> wrote in message
 news:3D10D500.141280D1 smartsoft.cc...
 I thought the newer compiler find masm 5.10 or masm 6.15 when it
 can find it in the path...

 Jan



 Nic Tiger wrote:

 Hi,

 Does anyone have or know where to find masm386?

 I need it in order to compile RTL (DMC 8.27).
 I cannot compile RTL ASM's with Masm 5.10 and Masm 6.15.

 Any suggestions?

 Looking forward for an answer,
         Nic Tiger.



Jun 20 2002