www.digitalmars.com         C & C++   DMDScript  

D.gnu - Overhaul filename convention

reply "Iain Buclaw" <ibuclaw gdcproject.org> writes:
Hi,

I've been thinking about this in the back of my head for a while, 
but thought now would be a good time to raise it with the new 
release and impending visitor-related conversion changes.

The current naming convention for glue files is currently the 
prefix d- followed by the name. eg: d-objfile.cc.  This is the 
case for all glue files.

What I propose is to remove the prefix for all files except those 
whose role is to specifically provide an interface between the 
glue and backend, and those that share a common name with gcc or 
other frontends.

This would be something akin to:

asmstmt.cc      d-tree.def
ChangeLog       elem.cc
ChangeLog-2006  gdc.texi
ChangeLog-2007  glue.cc
ChangeLog-2008  intrinsics.cc
ChangeLog-2009  irstate.cc
ChangeLog-2010  irstate.h
ChangeLog-2011  lang.opt
ChangeLog-2012  lang-specs.h
ChangeLog-2013  longdouble.cc
codegen.cc      longdouble.h
codegen.h       Make-lang.in
config-lang.in  objfile.cc
ctype.cc        objfile.h
d-convert.cc    patches
d-dmd-gcc.h     port.cc
decls.cc        README
dfrontend       target.cc
d-gt.c          target-ver-syms.sh
d-incpath.cc    todt.cc
d-lang.cc       toir.cc
d-lang.h        typinf.cc
d-spec.c        VERSION
d-system.h


Any thoughts?  (I know Johannes, you are probably the only one 
affected here :)

Regards
Iain.
Feb 24 2014
next sibling parent reply Johannes Pfau <nospam example.com> writes:
Am Mon, 24 Feb 2014 17:07:21 +0000
schrieb "Iain Buclaw" <ibuclaw gdcproject.org>:

 Hi,
 
 I've been thinking about this in the back of my head for a while, 
 but thought now would be a good time to raise it with the new 
 release and impending visitor-related conversion changes.
 
 The current naming convention for glue files is currently the 
 prefix d- followed by the name. eg: d-objfile.cc.  This is the 
 case for all glue files.
 
 [...]
 
 
 Any thoughts?  (I know Johannes, you are probably the only one 
 affected here :)
 
 Regards
 Iain.

Sounds good to me.
Feb 24 2014
parent reply "Daniel Murphy" <yebbliesnospam gmail.com> writes:
"Iain Buclaw"  wrote in message 
news:mailman.286.1393282527.6445.d.gnu puremagic.com...

 OK, rather than all at once, I'll move each file with each visitor
 conversion.  First one is d-toir.cc -> toir.cc in the 2.065 merge. :)

And give them better names while you're at it?
Feb 25 2014
parent "Daniel Murphy" <yebbliesnospam gmail.com> writes:
"Iain Buclaw"  wrote in message 
news:mailman.306.1393348468.6445.d.gnu puremagic.com...

 And give them better names while you're at it?

Visitor names? I was thinking IRVisitor, and build_ir (). ;)

I mean, you have todt.c with all the toDt methods, which you are now free to call something meaningful to gcc.
Feb 26 2014
prev sibling next sibling parent Iain Buclaw <ibuclaw gdcproject.org> writes:
On 24 February 2014 17:15, Johannes Pfau <nospam example.com> wrote:
 Am Mon, 24 Feb 2014 17:07:21 +0000
 schrieb "Iain Buclaw" <ibuclaw gdcproject.org>:

 Hi,

 I've been thinking about this in the back of my head for a while,
 but thought now would be a good time to raise it with the new
 release and impending visitor-related conversion changes.

 The current naming convention for glue files is currently the
 prefix d- followed by the name. eg: d-objfile.cc.  This is the
 case for all glue files.

 [...]


 Any thoughts?  (I know Johannes, you are probably the only one
 affected here :)

 Regards
 Iain.

Sounds good to me.

OK, rather than all at once, I'll move each file with each visitor conversion. First one is d-toir.cc -> toir.cc in the 2.065 merge. :)
Feb 24 2014
prev sibling next sibling parent Iain Buclaw <ibuclaw gdcproject.org> writes:
On 25 February 2014 15:39, Daniel Murphy <yebbliesnospam gmail.com> wrote:
 "Iain Buclaw"  wrote in message
 news:mailman.286.1393282527.6445.d.gnu puremagic.com...


 OK, rather than all at once, I'll move each file with each visitor
 conversion.  First one is d-toir.cc -> toir.cc in the 2.065 merge. :)

And give them better names while you're at it?

Visitor names? I was thinking IRVisitor, and build_ir (). ;)
Feb 25 2014
prev sibling parent Iain Buclaw <ibuclaw gdcproject.org> writes:
On 26 February 2014 11:48, Daniel Murphy <yebbliesnospam gmail.com> wrote:
 "Iain Buclaw"  wrote in message
 news:mailman.306.1393348468.6445.d.gnu puremagic.com...

 And give them better names while you're at it?

Visitor names? I was thinking IRVisitor, and build_ir (). ;)

I mean, you have todt.c with all the toDt methods, which you are now free to call something meaningful to gcc.

That's d-todt.cc - But yes, that is the plan. Not that anything we name needs to be meaningful to gcc.
Feb 26 2014