www.digitalmars.com         C & C++   DMDScript  

D.gnu - Build error for gdc-0.19

reply =?ISO-8859-15?Q?Dominique_W=FCrtz?= <housirer gmx.de> writes:
Hi,

I'm trying to build gdc-0.19 with gcc-4.0.3 under Ubuntu Edgy and get 
the following error:

# make

...

checking If /home/dude/sources/gcc-build/gcc/gdc 
-B/home/dude/sources/gcc-build/gcc/ -B/usr/i686-pc-linux-gnu/bin/ 
-B/usr/i686-pc-linux-gnu/lib/ -isystem /usr/i686-pc-linux-gnu/include 
-isystem /usr/i686-pc-linux-gnu/sys-include can compile D sources... 
/home/dude/sources/gcc-build/gcc/cc1d: 
/home/dude/sources/gcc-build/gcc/libgcc_s.so.1: version `GCC_4.2.0' not 
found (required by /usr/lib/libstdc++.so.6)
no
configure: error: can't compile D sources!
make: *** [configure-target-libphobos] Fehler 1


Any ideas what to do about this?

Regards,
Dominique
Sep 18 2006
next sibling parent reply Vincenzo Ampolo <vincenzo.ampolo gmail.com> writes:
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

On Mon, 2006-09-18 at 18:15 +0200, Dominique W=C3=BCrtz wrote:
 /home/dude/sources/gcc-build/gcc/libgcc_s.so.1: version `GCC_4.2.0'
 not=20
 found (required by /usr/lib/libstdc++.so.6)=20

Sure, i had the same :D you are using gcc 4.1 and gdc doesn't support it. Try building with gcc-4.0, if you are using pbuilder tell me that i'll give you a trick. btw i'm working to create .deb package of gdc on dapper and debian. stay tuned! --=20 Vincenzo Ampolo http://www.nanofreesoft.org http://vincenzoampolo.nanofreesoft.org http://idp.nanofreesoft.org
Sep 18 2006
parent reply =?UTF-8?B?RG9taW5pcXVlIFfDvHJ0eg==?= <housirer gmx.de> writes:
Vincenzo Ampolo schrieb:
 On Mon, 2006-09-18 at 18:15 +0200, Dominique W├╝rtz wrote:
 /home/dude/sources/gcc-build/gcc/libgcc_s.so.1: version `GCC_4.2.0'
 not 
 found (required by /usr/lib/libstdc++.so.6) 

Sure, i had the same :D you are using gcc 4.1 and gdc doesn't support it.

I did explicitly use CC="gcc-4.0" CXX="g++-4.0". OTOH, the libstdc++ package version is 4.1.1, could this be the problem? I did not find a 4.0 version in the repos.
 Try building with gcc-4.0, if you are using pbuilder tell me that i'll
 give you a trick.
 
 btw i'm working to create .deb package of gdc on dapper and debian. stay
 tuned!

Great!
Sep 19 2006
parent =?UTF-8?B?QW5kZXJzIEYgQmrDtnJrbHVuZA==?= <afb algonet.se> writes:
Vincenzo Ampolo wrote:

 It seems that you cannot compile gdc on edgy, try to build it in a
 dapper environment though.
 Use pbuilder to create a clean dapper environment under edgy...

For Fedora Core 5, I've found it easiest to bootstrap the entire GCC with a supported version such as 4.0.3. I even had to use the "compat32" compiler to do so, since system compiler is 4.1 (the RPM spec file is at http://www.algonet.se/~afb/d/gdc.spec) As a bonus you also get a vanilla C and C++ compiler, should you ever need one not patched silly by your distribution of choice :-) --anders
Sep 19 2006
prev sibling parent Vincenzo Ampolo <vincenzo.ampolo gmail.com> writes:
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

On Tue, 2006-09-19 at 09:32 +0200, Dominique W=C3=BCrtz wrote:
 I did explicitly use CC=3D"gcc-4.0" CXX=3D"g++-4.0". OTOH, the libstdc++=20
 package version is 4.1.1, could this be the problem? I did not find a=20
 4.0 version in the repos.=20

The problem should be the libstdc++. If you go here: http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=3Dlibstdc% 2B%2B&searchon=3Dnames&subword=3D1&version=3Dedgy&release=3Dall you will find that libstdc++ is at version 4.1.1 as you already know but there are also another kind of packages like this one "libstdc ++6-4.0-dev" that provides development file fot the correct version of libstdc++ that you need. It seems that you cannot compile gdc on edgy, try to build it in a dapper environment though. Use pbuilder to create a clean dapper environment under edgy... --=20 Vincenzo Ampolo http://www.nanofreesoft.org http://vincenzoampolo.nanofreesoft.org http://idp.nanofreesoft.org
Sep 19 2006