www.digitalmars.com         C & C++   DMDScript  

D.gnu - Does anybody use GCC 3.3 and 3.4?

reply David Friedman <dvdfrdmn users.ess-eff.net> writes:
Maintaining support for three different versions of GCC is cumbersome 
and I have yet to support 4.1.x series.  Obviously, MinGW and Cygwin 
users need 3.4, but is there a need for 3.4 beyond this?  Is anyone 
using 3.3?

David
May 27 2006
next sibling parent =?ISO-8859-1?Q?Anders_F_Bj=F6rklund?= <afb algonet.se> writes:
David Friedman wrote:

 Maintaining support for three different versions of GCC is cumbersome 
 and I have yet to support 4.1.x series.  Obviously, MinGW and Cygwin 
 users need 3.4, but is there a need for 3.4 beyond this?  Is anyone 
 using 3.3?

Mac OS X 10.3 (and 10.2) use GCC 3.3, but have problems with templates. --anders
May 27 2006
prev sibling next sibling parent Thomas Kuehne <thomas-dloop kuehne.cn> writes:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

David Friedman schrieb am 2006-05-27:
 Maintaining support for three different versions of GCC is cumbersome 
 and I have yet to support 4.1.x series.  Obviously, MinGW and Cygwin 
 users need 3.4, but is there a need for 3.4 beyond this?  Is anyone 
 using 3.3?

Gentoo currently uses 3.4.5/3.4.6. Thomas -----BEGIN PGP SIGNATURE----- iD8DBQFEeV3x3w+/yD4P9tIRApPRAKDQie5rxVgeNAz1rWpwM5QIuFeMuQCfaVFp AkcojR9UZvOHem7rVNfxnpQ= =SIbh -----END PGP SIGNATURE-----
May 28 2006
prev sibling parent Robert Jones <robertjones21 HotPOP.com> writes:
David Friedman said the following on 5/27/2006 1:20 PM:
 
 Maintaining support for three different versions of GCC is cumbersome 
 and I have yet to support 4.1.x series.  Obviously, MinGW and Cygwin 
 users need 3.4, but is there a need for 3.4 beyond this?  Is anyone 
 using 3.3?
 
 David

I am a cygwin user who compiled gcc 4.0.2. So I am not concerned with 3.x support. Not so sure of others. And, David, It's nice to know you are still alive and working on gdc. -- Robert Jones robertjones21 hotpop.com
Jun 02 2006