www.digitalmars.com         C & C++   DMDScript  

c++ - newsgroup moved to new server...

reply Jan Knepper <jan smartsoft.us> writes:
All,

The newsgroups (actually digitalmars.com) has moved to a new server with 
much more processor power Dual Opteron 2.0 Ghz, with 8 times as much RAM 
and about 8 times as much disk space). Overall this should result in an 
8*+ or so improvement.

Unfortunately there were some issue's getting all the news articles 
moved over. It should be fine now and posting should work again as well. 
However, the articles might all show as un-read when you reconnect to 
news.digitalmars.com. (They did for me in Thunderbird 
www.mozilla.org/thunderbird/). I am not sure that there is anything I 
could do to prevent this at this moment.

Let me know if there are any problems.

Thanks!
Jan



-- 
ManiaC++
Jan Knepper

But as for me and my household, we shall use Mozilla...
www.mozilla.org
Jul 22 2006
next sibling parent "Derek Parnell" <derek psych.ward> writes:
On Sun, 23 Jul 2006 05:52:07 +1000, Jan Knepper <jan smartsoft.us> wrote:

 All,

 The newsgroups (actually digitalmars.com) has moved to a new server

 Let me know if there are any problems.

I'm using Opera (at home) and there were no problems at all. I'll log in with 40tude at the office tomorrow and let you know if there are any issues there. -- Derek Parnell Melbourne, Australia
Jul 22 2006
prev sibling next sibling parent reply Kirk McDonald <kirklin.mcdonald gmail.com> writes:
Jan Knepper wrote:
 All,
 
 The newsgroups (actually digitalmars.com) has moved to a new server with 
 much more processor power Dual Opteron 2.0 Ghz, with 8 times as much RAM 
 and about 8 times as much disk space). Overall this should result in an 
 8*+ or so improvement.
 
 Unfortunately there were some issue's getting all the news articles 
 moved over. It should be fine now and posting should work again as well. 
 However, the articles might all show as un-read when you reconnect to 
 news.digitalmars.com. (They did for me in Thunderbird 
 www.mozilla.org/thunderbird/). I am not sure that there is anything I 
 could do to prevent this at this moment.
 
 Let me know if there are any problems.
 
 Thanks!
 Jan
 

I can't seem to access archived messages through Thunderbird. New messages are showing up fine. The web archive doesn't seem to be working, either. -- Kirk McDonald Pyd: Wrapping Python with D http://dsource.org/projects/pyd/wiki
Jul 22 2006
next sibling parent reply Jan Knepper <jan smartsoft.us> writes:
OK, rebuild the overview and history... I think that solved it...

Thanks!
Jan



Kirk McDonald wrote:

 Jan Knepper wrote:
 All,

 The newsgroups (actually digitalmars.com) has moved to a new server 
 with much more processor power Dual Opteron 2.0 Ghz, with 8 times as 
 much RAM and about 8 times as much disk space). Overall this should 
 result in an 8*+ or so improvement.

 Unfortunately there were some issue's getting all the news articles 
 moved over. It should be fine now and posting should work again as 
 well. However, the articles might all show as un-read when you 
 reconnect to news.digitalmars.com. (They did for me in Thunderbird 
 www.mozilla.org/thunderbird/). I am not sure that there is anything I 
 could do to prevent this at this moment.

 Let me know if there are any problems.

 Thanks!
 Jan

I can't seem to access archived messages through Thunderbird. New messages are showing up fine. The web archive doesn't seem to be working, either.

Jul 22 2006
parent reply Kirk McDonald <kirklin.mcdonald gmail.com> writes:
Jan Knepper wrote:
 OK, rebuild the overview and history... I think that solved it...
 
 Thanks!
 Jan
 

Okay, it's working now. The web archive is still spitting out a 500 error, however: http://www.digitalmars.com/drn-bin/wwwnews?digitalmars.D -- Kirk McDonald Pyd: Wrapping Python with D http://dsource.org/projects/pyd/wiki
Jul 22 2006
parent reply Jan Knepper <jan smartsoft.us> writes:
Yeah... that's because there as some issue's running the 32 bits 
executable on a 64 bits operating system.
Trying to figure those out...

/usr/libexec/ld-elf.so.1: Undefined symbol "cerr" referenced from COPY 
relocation in <executable>

It has to do with the <executable> being linked against the dynamic 
libraries... If it would be static this would not be a problem. 
However... I do not have the sources... <sigh>

Jan



Kirk McDonald wrote:
 Jan Knepper wrote:
 OK, rebuild the overview and history... I think that solved it...

 Thanks!
 Jan

Okay, it's working now. The web archive is still spitting out a 500 error, however: http://www.digitalmars.com/drn-bin/wwwnews?digitalmars.D

-- ManiaC++ Jan Knepper But as for me and my household, we shall use Mozilla... www.mozilla.org
Jul 22 2006
parent reply Justin C Calvarese <technocrat7 gmail.com> writes:
Jan Knepper wrote:
 Yeah... that's because there as some issue's running the 32 bits 
 executable on a 64 bits operating system.
 Trying to figure those out...
 
 /usr/libexec/ld-elf.so.1: Undefined symbol "cerr" referenced from COPY 
 relocation in <executable>
 
 It has to do with the <executable> being linked against the dynamic 
 libraries... If it would be static this would not be a problem. 
 However... I do not have the sources... <sigh>
 
 Jan

Since "500 Internal Server Error" could be showing up for a long time, perhaps the URLs that start with "http://www.digitalmars.com/drn-bin/wwwnews" should redirect to a simple page mentioning that the problem is being worked on, but in the meantime people will need to use an actual newsreader and offer a link to http://www.digitalmars.com/NewsGroup.html. (I don't really know how the how the web interface works. But I suppose if running it on a 32-bit machine were an option, you would've already done that.) For those that are truly desperate for news about D but lack newsgroup access, recent D-related posts can be viewed from http://lists.puremagic.com/mailman/listinfo. -- jcc7
Jul 27 2006
parent Jan Knepper <jan smartsoft.us> writes:
Working on a replacement of that system. There are several web based 
systems out there. It just a matter of finding one that fits. The 
newsguy stuff was great and it was free.

Thanks!
Jan



Justin C Calvarese wrote:
 Jan Knepper wrote:
 Yeah... that's because there as some issue's running the 32 bits 
 executable on a 64 bits operating system.
 Trying to figure those out...

 /usr/libexec/ld-elf.so.1: Undefined symbol "cerr" referenced from COPY 
 relocation in <executable>

 It has to do with the <executable> being linked against the dynamic 
 libraries... If it would be static this would not be a problem. 
 However... I do not have the sources... <sigh>

 Jan

Since "500 Internal Server Error" could be showing up for a long time, perhaps the URLs that start with "http://www.digitalmars.com/drn-bin/wwwnews" should redirect to a simple page mentioning that the problem is being worked on, but in the meantime people will need to use an actual newsreader and offer a link to http://www.digitalmars.com/NewsGroup.html. (I don't really know how the how the web interface works. But I suppose if running it on a 32-bit machine were an option, you would've already done that.) For those that are truly desperate for news about D but lack newsgroup access, recent D-related posts can be viewed from http://lists.puremagic.com/mailman/listinfo.

-- ManiaC++ Jan Knepper But as for me and my household, we shall use Mozilla... www.mozilla.org
Jul 27 2006
prev sibling parent "Unknown W. Brackets" <unknown simplemachines.org> writes:
Weird, I use Thunderbird... everything was marked somewhat weird but now 
everything is fine, I have old posts, I have what I've read previously, etc.

Odd.

-[Unknown]

 Jan Knepper wrote:
 All,

 The newsgroups (actually digitalmars.com) has moved to a new server 
 with much more processor power Dual Opteron 2.0 Ghz, with 8 times as 
 much RAM and about 8 times as much disk space). Overall this should 
 result in an 8*+ or so improvement.

 Unfortunately there were some issue's getting all the news articles 
 moved over. It should be fine now and posting should work again as 
 well. However, the articles might all show as un-read when you 
 reconnect to news.digitalmars.com. (They did for me in Thunderbird 
 www.mozilla.org/thunderbird/). I am not sure that there is anything I 
 could do to prevent this at this moment.

 Let me know if there are any problems.

 Thanks!
 Jan

I can't seem to access archived messages through Thunderbird. New messages are showing up fine. The web archive doesn't seem to be working, either.

Jul 22 2006
prev sibling next sibling parent "Rajiv Bhagwat" <dataflow vsnl.com> writes:
Thanks for the move. Now everything works great in Outlook Express. For the
first time in years instead of thousands of unread messages, I am seeing
1-10, which is the correct number.
- Rajiv Bhagwat



"Jan Knepper" <jan smartsoft.us> wrote in message
news:e9tvl9$km5$1 opteron.digitaldaemon.com...
 All,

 The newsgroups (actually digitalmars.com) has moved to a new server with
 much more processor power Dual Opteron 2.0 Ghz, with 8 times as much RAM
 and about 8 times as much disk space). Overall this should result in an
 8*+ or so improvement.

 Unfortunately there were some issue's getting all the news articles
 moved over. It should be fine now and posting should work again as well.
 However, the articles might all show as un-read when you reconnect to
 news.digitalmars.com. (They did for me in Thunderbird
 www.mozilla.org/thunderbird/). I am not sure that there is anything I
 could do to prevent this at this moment.

 Let me know if there are any problems.

 Thanks!
 Jan



 -- 
 ManiaC++
 Jan Knepper

 But as for me and my household, we shall use Mozilla...
 www.mozilla.org

Jul 23 2006
prev sibling parent reply "TK" <tk tech-head.ic24.nein-spam.net> writes:
"Jan Knepper" <jan smartsoft.us> wrote in message
news:e9tvl9$km5$1 opteron.digitaldaemon.com...
 All,

 The newsgroups (actually digitalmars.com) has moved to a new server with
 much more processor power Dual Opteron 2.0 Ghz, with 8 times as much RAM
 and about 8 times as much disk space). Overall this should result in an
 8*+ or so improvement.

 Unfortunately there were some issue's getting all the news articles
 moved over. It should be fine now and posting should work again as well.
 However, the articles might all show as un-read when you reconnect to
 news.digitalmars.com. (They did for me in Thunderbird
 www.mozilla.org/thunderbird/). I am not sure that there is anything I
 could do to prevent this at this moment.

 Let me know if there are any problems.

 Thanks!
 Jan

No thank you! with the transfer you've managed to squash that article numbering bug that left an unread article count even after all articles had been read in the groups, finally it tells the truth. None of the problem you mention with thunderbird are experienced in OE 5.5SP2... was nice to watch the unread count drop to zero just by selecting the newsgroup on the in-active newsgroups for a change:-)
Aug 01 2006
parent reply Jan Knepper <jan smartsoft.us> writes:
TK wrote:
 No thank you! with the transfer you've managed to squash that article
 numbering bug that left an unread article count even after all articles had
 been read in the groups, finally it tells the truth. None of the problem you
 mention with thunderbird are experienced in OE 5.5SP2... was nice to watch
 the unread count drop to zero just by selecting the newsgroup on the
 in-active newsgroups for a change:-)

The problems in Thunderbird (if any) are because I hit the server in between (before I fixed that numbering problem) I think. It can be easily solved by stopping Thunderbird, removing the files from disk and restarting Thunderbird and downloading the articles again. NP to do that with Thunderbird. Jan -- ManiaC++ Jan Knepper But as for me and my household, we shall use Mozilla... www.mozilla.org
Aug 01 2006
parent jose cabrera <cabrera wrc.xerox.com> writes:
Jan,

is there any way that I can set setting on the reply screen?  It's
tough to keep typing the email and name all the time.

thanks.

josť
Sep 28 2006